Bug 1661741 - SELinux is preventing abrt-handle-eve from 'unlink' accesses on the lnk_file .lock.
Summary: SELinux is preventing abrt-handle-eve from 'unlink' accesses on the lnk_file ...
Keywords:
Status: CLOSED DUPLICATE of bug 1661735
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:65147f1c8f8f4d20ca7a6828d5d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-22 19:19 UTC by Mikhail
Modified: 2018-12-25 11:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-25 11:02:55 UTC


Attachments (Terms of Use)

Description Mikhail 2018-12-22 19:19:49 UTC
Description of problem:
SELinux is preventing abrt-handle-eve from 'unlink' accesses on the lnk_file .lock.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-handle-eve should be allowed unlink access on the .lock lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'abrt-handle-eve' --raw | audit2allow -M my-abrthandleeve
# semodule -X 300 -i my-abrthandleeve.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                .lock [ lnk_file ]
Source                        abrt-handle-eve
Source Path                   abrt-handle-eve
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.3-15.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.20.0-0.rc7.git1.1.fc30.x86_64 #1
                              SMP Tue Dec 18 22:52:01 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-12-23 00:17:11 +05
Last Seen                     2018-12-23 00:17:11 +05
Local ID                      e2d90cca-ee3c-4efb-a4e7-e5cbb60820e0

Raw Audit Messages
type=AVC msg=audit(1545506231.485:378): avc:  denied  { unlink } for  pid=15230 comm="abrt-handle-eve" name=".lock" dev="nvme0n1p2" ino=3279383 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:unlabeled_t:s0 tclass=lnk_file permissive=1


Hash: abrt-handle-eve,abrt_t,unlabeled_t,lnk_file,unlink

Version-Release number of selected component:
selinux-policy-3.14.3-15.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.7
hashmarkername: setroubleshoot
kernel:         4.20.0-0.rc7.git1.1.fc30.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2018-12-25 11:02:55 UTC
Seems to be a duplicate of bz 1661735.

Hence closing, feel free to reopen this bugzilla if the issue turns out to be different.

*** This bug has been marked as a duplicate of bug 1661735 ***


Note You need to log in before you can comment on or make changes to this bug.