Bug 1661922 - hplip-3.18.6-11 uninstallable because of missing libnetsnmp.so.35()(64bit)
Summary: hplip-3.18.6-11 uninstallable because of missing libnetsnmp.so.35()(64bit)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1662300 1663313 1663341 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-24 13:14 UTC by Tomasz Torcz
Modified: 2019-01-04 08:22 UTC (History)
12 users (show)

Fixed In Version: hplip-3.18.6-12.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-04 03:23:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomasz Torcz 2018-12-24 13:14:31 UTC
Description of problem:
Last metadata expiration check: 0:27:53 ago on Mon 24 Dec 2018 01:41:30 PM CET.                                                                                    [0/1898]
Dependencies resolved.                      
                                             
 Problem 1: cannot install the best update candidate for package hplip-3.18.6-10.fc28.x86_64                                                                              
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64
 Problem 2: cannot install the best update candidate for package hplip-libs-3.18.6-10.fc28.x86_64                                                                         
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64                                                                                 
 Problem 3: cannot install the best update candidate for package libsane-hpaio-3.18.6-10.fc28.x86_64                                                                      
  - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64                                                                              
 Problem 4: package hplip-libs-3.18.6-10.fc28.x86_64 requires hplip-common(x86-64) = 3.18.6-10.fc28, but none of the providers can be installed                           
  - cannot install both hplip-common-3.18.6-11.fc28.x86_64 and hplip-common-3.18.6-10.fc28.x86_64                                                                         
  - problem with installed package hplip-libs-3.18.6-10.fc28.x86_64
  - cannot install the best update candidate for package hplip-common-3.18.6-10.fc28.x86_64                                                                               
  - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64         

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 James Crawford 2018-12-26 16:21:21 UTC
Looks like only libnetsnmp.so.30 is the only version currently in Fedora 28 repos.


dnf whatprovides "libnetsnmp.so.*"
Last metadata expiration check: 0:12:03 ago on Wed 26 Dec 2018 08:59:45 AM MST.
net-snmp-libs-1:5.7.3-38.fc28.x86_64 : The NET-SNMP runtime client libraries
Repo        : @System
Matched from:
Provide    : libnetsnmp.so.30()(64bit)

net-snmp-libs-1:5.7.3-38.fc28.i686 : The NET-SNMP runtime client libraries
Repo        : updates
Matched from:
Provide    : libnetsnmp.so.30

net-snmp-libs-1:5.7.3-38.fc28.x86_64 : The NET-SNMP runtime client libraries
Repo        : updates
Matched from:
Provide    : libnetsnmp.so.30()(64bit)

net-snmp-libs-1:5.7.3-36.fc28.i686 : The NET-SNMP runtime client libraries
Repo        : fedora
Matched from:
Provide    : libnetsnmp.so.30

net-snmp-libs-1:5.7.3-36.fc28.x86_64 : The NET-SNMP runtime client libraries
Repo        : fedora
Matched from:
Provide    : libnetsnmp.so.30()(64bit)

Comment 2 Zdenek Dohnal 2019-01-02 09:26:30 UTC
*** Bug 1662300 has been marked as a duplicate of this bug. ***

Comment 3 Zdenek Dohnal 2019-01-02 09:34:25 UTC
Hi,

thank you for reporting the issue! I'm deeply sorry for inconvenience, I pushed the update without cross checking if new net-snmp is already in the stable (I wasn't able to add hplip to net-snmp update) and I went on vacation after that.
You can install previous version from koji for now https://koji.fedoraproject.org/koji/buildinfo?buildID=1163784 .

Comment 4 Fedora Update System 2019-01-02 11:21:54 UTC
hplip-3.18.6-12.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-96487fdb77

Comment 5 John Griffiths 2019-01-02 15:15:39 UTC
This error is also caused by hplip-libs.

nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64

Comment 6 Fedora Update System 2019-01-03 04:00:23 UTC
hplip-3.18.6-12.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-96487fdb77

Comment 7 Fedora Update System 2019-01-04 03:23:35 UTC
hplip-3.18.6-12.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Zdenek Dohnal 2019-01-04 08:21:51 UTC
*** Bug 1663341 has been marked as a duplicate of this bug. ***

Comment 9 Zdenek Dohnal 2019-01-04 08:22:25 UTC
*** Bug 1663313 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.