Bug 1661943 - after updating the kernel, ethernet is broken
Summary: after updating the kernel, ethernet is broken
Keywords:
Status: CLOSED DUPLICATE of bug 1650984
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-24 17:03 UTC by oli
Modified: 2018-12-24 20:46 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-24 20:46:52 UTC
Type: Bug


Attachments (Terms of Use)
dmesg (67.97 KB, text/plain)
2018-12-24 17:03 UTC, oli
no flags Details

Description oli 2018-12-24 17:03:15 UTC
Created attachment 1516583 [details]
dmesg

Description of problem:
my network device (ethernet) does not work anymore after i updated the kernel from 4.18 to 4.19

Version-Release number of selected component (if applicable):
vmlinuz-4.19.10-300.fc29.x86_64

How reproducible:
install vmlinuz-4.18.12-300.fc29.x86_64, then update to 
vmlinuz-4.19.10-300.fc29.x86_64

Steps to Reproduce:
1.
2.
3.

Actual results:
the device does not get any link

Expected results:
being able to connect to the router

Additional info:

Comment 1 oli 2018-12-24 17:04:44 UTC
At the moment i boot the old kernel 4.18.x where i get an network connection, i believe it is somehow related to https://bugzilla.redhat.com/show_bug.cgi?id=1654858

Comment 2 Hans de Goede 2018-12-24 20:46:52 UTC
Since you point to bug 165858 I assume you have a realtek ethernet controller? There indeed is an issue with realtek ethernet controllers in 4.19, this is being discussed in bug 1650984.

Bug 1650984 comment 62 has a patch which is believed to fix this, hopefully we will have a kernel update with that patch available soon, but I'm not sure any updates will be done before the Christmas Holiday is over.

*** This bug has been marked as a duplicate of bug 1650984 ***


Note You need to log in before you can comment on or make changes to this bug.