Bug 1662065 - Use SNI when connecting with SSL
Summary: Use SNI when connecting with SSL
Keywords:
Status: CLOSED DUPLICATE of bug 1632958
Alias: None
Product: Fedora
Classification: Fedora
Component: isync
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-25 20:09 UTC by Cedric Buissart 🐶
Modified: 2019-05-13 06:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-13 06:53:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Cedric Buissart 🐶 2018-12-25 20:09:02 UTC
Description of problem:

isync fails with the following error :

SSL error connecting imap.gmail.com (74.125.133.109:993): self signed certificate


Version-Release number of selected component (if applicable): current Fedora 29


How reproducible: 100%


Steps to Reproduce:
1. configure isync to use imap.gmail.com with IMAPS:
Host imap.gmail.com
SSLType IMAPS

2. try connecting :
$ mbsync <mailbox>

Actual results:

SSL error connecting imap.gmail.com (74.125.133.109:993): self signed certificate

Expected results:

Successful sync

Additional info:

Looking at the exchange, the server returns "uTF8String: No SNI provided; please fix your client."

This seems to be the following bug :
https://sourceforge.net/p/isync/isync/merge-requests/2/

Fix: https://sourceforge.net/u/vbernat/isync/ci/1086cdb8fd77a224d56033bde0825a286ba30ee2/

Comment 1 Cedric Buissart 🐶 2018-12-26 19:42:29 UTC
I tried the fix in $descr and it works

Comment 2 Christophe Fergeau 2019-05-13 06:53:48 UTC

*** This bug has been marked as a duplicate of bug 1632958 ***


Note You need to log in before you can comment on or make changes to this bug.