Bug 166210 - microcode device /dev/cpu/microcode doesn't exist? after upgrade to RHEL4
microcode device /dev/cpu/microcode doesn't exist? after upgrade to RHEL4
Status: CLOSED DUPLICATE of bug 160833
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Regression
: 173861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-17 17:04 EDT by Brian McEntire
Modified: 2015-01-04 17:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 02:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian McEntire 2005-08-17 17:04:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Debian/1.7.8-1

Description of problem:
When switching from various run levels (to diagnose a separate problem (XDMCP access) I see these warnings:

/etc/init.d/microcode_ctl: microcode device /dev/cpu/microcode doesn't exist?


Indeed /dev/cpu/microcode does not exist. 

If I 'modprobe microcode'

The directory is created (actually a symlink):
# ls -ld /dev/cpu/microcode
lrwxrwxrwx  1 root root 12 Aug 17 16:58 /dev/cpu/microcode -> ../microcode

 
Rerunning /etc/sbin/init.d/microcode_ctl (as will happen when switching to a higher run level) now works:
# service microcode_ctl start
Applying Intel Microcode update:                           [  OK  ]


However, if I run it again (or drop run levels and later up the run level) the warning comes back:
# service microcode_ctl start
/etc/init.d/microcode_ctl: microcode device /dev/cpu/microcode doesn't exist?


It appears the cause of this is that the /etc/init.d/microcode boot script does an 'rmmod microcode' at the end of it's start routine.

This seems like a bug, or there should be a way to quiet this warning or prevent microcode_ctl from running each time I switch run levels.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-13.1.66

How reproducible:
Always

Steps to Reproduce:
1. On a booted system, run 'service microcode_ctl start'

or

1b. init 3, wait a few seconds, init 5, watch for the error on the console

  

Actual Results:  /etc/init.d/microcode_ctl: microcode device /dev/cpu/microcode doesn't exist?

Expected Results:  Applying Intel Microcode update:                           [  OK  ]


... or possibly something like:
Microcode update previously applied, skipping              [  OK  ]

Additional info:
Comment 1 Bert DeKnuydt 2005-09-08 09:05:31 EDT
Exactly the same story on FC4 ...
Comment 2 Florin Andrei 2005-09-13 15:58:00 EDT
I was able to fix this issue on FC4 by creating the executable file named
/etc/sysconfig/modules/microcode.modules with the following content:

#!/bin/sh
/sbin/modprobe microcode

After that microcode_ctl works fine when booting up.
Comment 3 Dave Jones 2005-09-14 01:55:46 EDT
There's been an FC4 errata for a while.  1.11-1.21 should have it fixed.
RHEL4 will have it fixed when U2 ships.
Comment 4 Florin Andrei 2005-09-14 01:58:58 EDT
(In reply to comment #3)
> There's been an FC4 errata for a while.  1.11-1.21 should have it fixed.
> RHEL4 will have it fixed when U2 ships.

And yet it's exactly 1.11-1.21 that didn't work after reboot on my FC4 system.
Creating the modules script fixed it.
Comment 5 Dave Jones 2005-09-14 02:15:08 EDT
argh. it's only fixed in rawhide right now. It's fixed in FC4 CVS too, just not
built. I'll build it and push it out right now (along with an update to the
microcode.dat)

Comment 6 Dave Jones 2005-09-14 02:20:54 EDT

*** This bug has been marked as a duplicate of 160833 ***
Comment 7 oliver b. 2005-11-22 18:54:01 EST
*** Bug 173861 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.