Bug 1662832 - [ESXi][RFE]Check OS disk type before upgrade RHEL7.6 to RHEL8.0 with leapp tool
Summary: [ESXi][RFE]Check OS disk type before upgrade RHEL7.6 to RHEL8.0 with leapp tool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: leapp-repository
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: ---
Assignee: Vojtech Sokol
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On: 1651803 1666730
Blocks: 1726660
TreeView+ depends on / blocked
 
Reported: 2019-01-02 06:43 UTC by ldu
Modified: 2019-07-10 05:52 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1726660 (view as bug list)
Environment:
Last Closed: 2019-02-15 02:44:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ldu 2019-01-02 06:43:28 UTC
Description of problem:
RHEL7.6 with LSI type disk can not boot after upgrade to RHEL8 because of Bug 1589826.
SCSI controllers of 'LSI Logic Parallel' and 'LSI Logic SAS' provided by VMware won't work for RHEL8 VM any more, consider some customer may use this kind of disk type, so we think it's better to do some disk check before upgrade, if detect the VM use this kind disk, then leapp tool will stop and warning the customer.

Version-Release number of selected component (if applicable):
Leapp: 0.4.0
RHEL7.6 - kernel-3.10.0-957.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install one RHEL7.6 with LSI disk type on ESXi6.7.
   Start the upgrade process with leapp tool:
   # leapp upgrade --debug 
2. Reboot after upgrade is finished.
6. Check the status


Actual results:
Because of lack of driver mpt*, the guest can not boot up with LSI disk type.

Expected results:
The LSI disk should be detected by leapp tool before upgrade to RHEL 8 when upgrade OS on VMware ESXi platform.

Additional info:

Comment 3 Yaju Cao 2019-01-03 10:27:45 UTC
Copied Lili's note about how to check what kind of SCSI controller is used.
-------------------------------------------------------------------
[root@bootp-73-199-238 ~]# lspci |grep SCSI
02:01.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 01)
03:00.0 Serial Attached SCSI controller: VMware PVSCSI SCSI Controller (rev 02)
13:00.0 Serial Attached SCSI controller: LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS (rev 01)

For the SCSI controller type, VMware PVSCSI SCSI Controller could upgrade to RHEL 8 and boot normally.
For the  "LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI"  and "LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS"  SCSI controller could not upgrade to RHEL 8, It need mpt* driver, so if detect these kind SCSI controller, upgrade should be inhibited.
-------------------------------------------------------------------
BTW, there is still possibility to add this LIS Logic(mpt* kernel module)support back to RHEL 8, it is under discussion in "Bug 1651803 - RHEL 8 Beta install fails on VMWare Workstation due to the lack of mptspi". Any way, we can try a solution to prevent user to upgrade in case it is not supported.

Comment 4 Petr Stodulka 2019-01-03 11:05:44 UTC
Moving to the correct component. Thanks for the provided output.

Comment 5 Yaju Cao 2019-01-31 10:47:41 UTC
Add dependency on the RHEL 8 storage bugs, if those bugs would all add back the mpt* drivers, then we don't need this feature.

Comment 6 ldu 2019-02-15 02:44:49 UTC
As the mpt related driver mptspi and mptsas had add back to rhel8, and also bug 1666730, 1651803 had been verified.
so I think we can close this bug.
Thanks very much!

Lili Du

Comment 7 Chris Donnelly 2019-07-03 05:05:46 UTC
Hello.

The LSI Controller will fail because of the following migration issue:  Migration from EXTS4 to XFS.
The Areca Controller will fail because of the following migration issue:  Migration from EXTS4 to XFS
The HighPoint RocketRaid controller will fail because of the following migration issue: Migration from EXTS4 to XFS

During the Red Hat Enterprise Linux (RHEL) 7.0 - 7.6 run; 10 year time span. Most administrators used the top three raid cards in the EXTS4 configuration.  Thus when the migration occurs to RHEL 8.0 most JBODS and RAID arrays will fail because they are on raid cards that have not been updated for the current software

See the following:

LSI Logic SAS3801E Dual SFF-8088 SAS/SATA:  supports red hat 3

Please ask if your client/customer has an outdated raid card before migration to Red Hat Enterprise Linux 8.0

- Chris Donnelly
m1rr0rm3

Comment 8 Petr Stodulka 2019-07-03 11:28:58 UTC
Thank you Chris for notification! I am going to create new issue fot this problem where this will be discussed.


Note You need to log in before you can comment on or make changes to this bug.