Bug 1726660 - some raid controllers fails after upgrade RHEL7.6 to RHEL8.0 becase of migration EXTS4 to XFS
Summary: some raid controllers fails after upgrade RHEL7.6 to RHEL8.0 becase of migrat...
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: leapp-repository
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Leapp team
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On: 1651803 1662832 1666730
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-03 11:35 UTC by Petr Stodulka
Modified: 2019-09-11 16:04 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1662832
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Stodulka 2019-07-03 11:35:24 UTC
+++ This bug was initially created as a clone of Bug #1662832 +++

--- Comment from Chris Donnelly on 2019-07-03 07:05:46 CEST ---

Hello.

The LSI Controller will fail because of the following migration issue:  Migration from EXTS4 to XFS.
The Areca Controller will fail because of the following migration issue:  Migration from EXTS4 to XFS
The HighPoint RocketRaid controller will fail because of the following migration issue: Migration from EXTS4 to XFS

During the Red Hat Enterprise Linux (RHEL) 7.0 - 7.6 run; 10 year time span. Most administrators used the top three raid cards in the EXTS4 configuration.  Thus when the migration occurs to RHEL 8.0 most JBODS and RAID arrays will fail because they are on raid cards that have not been updated for the current software

See the following:

LSI Logic SAS3801E Dual SFF-8088 SAS/SATA:  supports red hat 3

Please ask if your client/customer has an outdated raid card before migration to Red Hat Enterprise Linux 8.0

- Chris Donnelly
m1rr0rm3

Comment 2 Petr Stodulka 2019-07-03 11:39:37 UTC
Idu, Yaju, could you look at it? Is it possible to detect use of outdated card reliably in automated way, so we would inhibit the upgrade to RHEL 8 in such cases? In case it is possible, who is the best person that would work on that?

Comment 3 Petr Stodulka 2019-07-03 11:44:26 UTC
Just to be clear, detection & inhibit doesn't have to be the solution of the problem - that was just my tip. If it is possible to resolve the issue in way users will be able to upgrade without this problem, it would be better solution :) Anyway, the decision what will be solution for this problem depends on someone else.

Comment 4 ldu 2019-07-04 07:24:50 UTC
(In reply to pstodulk from comment #2)
> Idu, Yaju, could you look at it? Is it possible to detect use of outdated
> card reliably in automated way, so we would inhibit the upgrade to RHEL 8 in
> such cases? In case it is possible, who is the best person that would work
> on that?

Hi Pstodulk,
we can detect LSI Controller that on ESXi, just use the lspci command can filter the LSI Logic scsi controller. I am not clearly about how raid disk fails after upgrade to RHEL 8.0,
do you mean install RHEL 7.6 guest with EXT4 filesystem RAID disk, after upgrade to RHEL 8.0, the RAID disk would be failed?

I cc one of our developer Cathy, maybe she can give good suggestion for it.

@Cathy, could you help take look it?
Thanks very much!

Lili Du

Comment 5 Cathy Avery 2019-07-08 14:50:14 UTC
@pstodulk

We are going to need more information as to how this fails ( journalctl ) and lsmod and lspci output. Plus I don't understand how this migration process works. Please explain how migration or conversion from ext4 to xfs is done. This is done after the upgrade to rhel8? Please lay out the steps.

Cathy

Comment 6 Petr Stodulka 2019-07-09 14:44:31 UTC
Hi Cathy,
we are not doing any conversion from EXT4 to XFS during the upgrade process (as this is clearly even not possible in reliable way, right?). We do not even work with RAID storage. That's why I asked for person who is SSE for RAID (or storage let's say) and will work on that. To get the required info, I think that Chris is right person.

We can schedule a mtg to sync about the upgrades where we can explain you how upgrade works if you are not familiar with IPU 7 -> 8 yet.

Comment 7 Cathy Avery 2019-07-09 15:36:55 UTC
(In reply to pstodulk from comment #6)
Hi,

I am trying to understand the process that you are performing. The BZ mentions upgrade to RHEL 8 and/or "Migration from EXTS4 to XFS". The BZ says there is a failure. I am asking for a little more clarity as to what is going on at the time of the failure, the logs, lsmod and lspci output. If Chris can provide that information great.

Thanks,

Cathy


Note You need to log in before you can comment on or make changes to this bug.