Bug 166306 - Avoid setting LD_LIBRARY_PATH
Summary: Avoid setting LD_LIBRARY_PATH
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 168040 170244
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-18 21:58 UTC by dann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 21:21:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dann 2005-08-18 21:58:24 UTC
Description of problem:
/usr/bin/eclipse sets LD_LIBRARY_PATH.
LD_LIBRARY_PATH slows down application startup, especially if the application
uses a lot of shared libraries. 

Probably the reason that eclipse needs to set LD_LIBRARY_PATH is that firefox 
does not work without it. See: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161958


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.22

Comment 1 Andrew Overholt 2005-09-19 19:56:40 UTC
I've removed the LD_LIBRARY_PATH setting as per bug 168040 but I'm not sure if
it will still work with firefox.  I guess we'll have to see once we get a newly
built eclipse.

Comment 2 Andrew Overholt 2005-10-10 01:00:37 UTC
This will show up in the next rawhide build.  Currently, that's waiting on bug
170244.

Comment 3 Andrew Overholt 2005-10-11 11:21:57 UTC
This should show up in today's rawhide push (-15).

Comment 4 Andrew Overholt 2005-11-01 03:09:15 UTC
This is fixed in the proposed FC4 update (eclipse-3.1.1-1jpp_1fc.FC4.4).  The
fix for rawhide will have to wait on a fix for bug 133180 which is stopping me
building lucene on ia64 and ppc64 which is in turn stopping me re-building
Eclipse (since I want to add ia64 and ppc64) :) .

I guess I'll set up some good 'ol bug dependencies.

Comment 5 Andrew Overholt 2005-11-01 21:21:00 UTC
Okay, forgetting ia64 and ppc64 (which are new for FC Eclipse anyway), this is
now fixed.


Note You need to log in before you can comment on or make changes to this bug.