Bug 168040 - browser does not work in x86_64.
Summary: browser does not work in x86_64.
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse   
(Show other bugs)
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 166306
TreeView+ depends on / blocked
 
Reported: 2005-09-11 12:59 UTC by Ivan Martinez
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 02:40:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Martinez 2005-09-11 12:59:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050719 Fedora/1.7.10-1.5.1

Description of problem:
When opening an html file under eclipse, it does not work. Because the startup script search for browser in /usr/lib instead of /usr/lib64 

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.22

How reproducible:
Always

Steps to Reproduce:
1. Start Eclipse
2. Try to open an html file
3.
  

Actual Results:  It does not open the file on browser, because can't access browser object

Expected Results:  open the html for viewing

Additional info:

The patch for solving the problem

--- eclipse.ori 2005-09-09 13:17:05.000000000 -0300
+++ eclipse     2005-09-09 13:17:24.000000000 -0300
@@ -37,7 +37,7 @@

 # This makes the embedded browser work.
 if [ -z "$MOZILLA_FIVE_HOME" ]; then
-  XPCOM=$(ls -t /usr/lib/{mozilla,firefox}-*/libxpcom.so|head -n1)
+  XPCOM=$(ls -t /usr/{lib,lib64}/{mozilla,firefox}-*/libxpcom.so|head -n1)
   export MOZILLA_FIVE_HOME=$(dirname $XPCOM)
 fi
 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$MOZILLA_FIVE_HOME

Comment 1 Billy Biggs 2005-09-11 14:41:17 UTC
That part of the script should likely just be deleted.  The eclipse
executable will use the /etc/gre.d/gre.conf file to locate a
browser, and this should point at the correct Mozilla GRE to use
for embedding.

Comment 2 Ivan Martinez 2005-09-11 15:31:11 UTC
my system does not have the file  
/etc/gre.d/gre.conf

only the file :
/etc/gre.d/gre64.conf

in any case the 64 bit system must be considered.

Comment 3 Billy Biggs 2005-09-11 15:41:21 UTC
OK, then there are two bugs  :)

First off, we didn't know about gre64.conf vs gre.conf in eclipse. I have
filed this bug upstream and will fix it:

  http://bugs.eclipse.org/bugs/show_bug.cgi?id=109253

Secondly, the gre should be used for embedding, not whatever comes
first in that ls -t.  So, I still think those lines should be removed.

I guess the third bug is that the GRE stuff from mozilla is very poorly
documented. :)

Comment 4 Billy Biggs 2005-09-17 20:13:38 UTC
I have added support for gre64.conf in Eclipse upstream for 3.2M2.

Comment 5 Andrew Overholt 2005-09-19 19:56:32 UTC
Okay, I've removed the offending lines from eclipse.script (which I plan to
remove entirely in the future -- see bug 168726) and included Billy's patch in
rawhide.  I can't rebuild right now but when bug 168718 is resolved, we'll try
it out.  I'll put this in NEEDINFO in the mean time and once we get a new build,
can someone with an x86_64 system (the reporter?) either give more info or close
this bug?  I wonder if this will still work with firefox?  Thanks.

Comment 6 Ivan Martinez 2005-09-28 14:32:05 UTC
I have checked the development tree and didn't find a new version to test, all
versions are from august.

http://download.fedora.redhat.com/pub/fedora/linux/core/development/x86_64/Fedora/RPMS/

where I can get the new version to test ?

Comment 7 Andrew Overholt 2005-09-28 14:41:47 UTC
See comment 5.  I can't rebuild right now due to bug 168718.  Once that's
resolved, I'll post here and get you to try it out if you don't mind.

Thanks.

Comment 8 Andrew Overholt 2005-10-11 11:22:45 UTC
There will be new rawhide RPMs (-15) showing up today.  Please test if you can.
 Thanks.

Comment 9 Ivan Martinez 2005-10-14 18:08:31 UTC
ivanfm@a2800 yum.repos.d]$ sudo yum --enablerepo=development update eclipse*
.....
.....
Error: Unable to satisfy dependencies
Error: Package glibc-devel needs glibc = 2.3.5-10.3, this is not available.
Error: Package glibc-devel needs glibc-headers = 2.3.5-10.3, this is not available.

-------------------------------------
And it has added a lot of success dependencies.
This package can be used in Fc4 or I will have to create and rawhide system to
test ?

Comment 10 Andrew Overholt 2005-10-21 18:27:01 UTC
I'm going to put an update into FC4 updates-testing that will work without
getting rawhide gcc & glibc.  Thanks for trying :)

Comment 11 Ivan Martinez 2005-10-25 01:35:36 UTC
I have updated to version in updates-testing.
Now it does not give option to use internal browser, only external.
In 
Window -> preferences -> General -> Web Browser
the "Use Internal WebBrowser" is disabled.

Now I only can view the html using the external browser.

Comment 12 Andrew Overholt 2005-10-25 14:46:29 UTC
Hmm.  I built with Billy's gre64.conf patch and the LD_LIBRARY_PATH stuff is
removed from eclipse.script (/usr/bin/eclipse).  I have no problem on x86 but
unfortunately I don't have a readily-available x86_64 machine on which to test.
 I'll see what I can do.  Anybody else have any ideas?

Comment 13 Andrew Overholt 2005-10-27 18:29:20 UTC
I found the problem.  The launcher (which Billy's patch touches) is actually
built by unzipping launchersrc.zip which I wasn't actually patching.  I'll put a
build in now and push it out as a test update tomorrow.  Sorry.

Comment 14 Ivan Martinez 2005-11-01 02:10:21 UTC
working now.
thanks

Comment 15 Andrew Overholt 2005-11-01 02:40:42 UTC
Great.  Closing.


Note You need to log in before you can comment on or make changes to this bug.