Bug 1663204 - kernel-4.19.12-301 fails to boot on AMD Athlon 200GE
Summary: kernel-4.19.12-301 fails to boot on AMD Athlon 200GE
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 12:16 UTC by nbogiatzoglou
Modified: 2019-01-30 15:10 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-30 15:10:49 UTC


Attachments (Terms of Use)
log files (35.91 KB, application/zip)
2019-01-03 12:16 UTC, nbogiatzoglou
no flags Details

Description nbogiatzoglou 2019-01-03 12:16:40 UTC
Created attachment 1518130 [details]
log files

Description of problem:
kernel-4.18.16-300 fails to boot on AMD Athlon 200GE with integrated Radeon graphics. All updates (as of 20190103) have been applied, linux-firmware-20181219-89.git0f22c852.fc29.noarch is installed and initramfs for this kernel has been updated with the command: dracut --kver 4.19.12-301.fc29.x86_64 --force. 

The solution provided for Bug 1659810 (https://bugzilla.redhat.com/show_bug.cgi?id=1659810) does not solve the problem.

The previous kernel, kernel-4.18.16-300 boots most of the times although, sometimes, it also fails.

Version-Release number of selected component (if applicable):
kernel-4.19.12-301.fc29.x86_64

How reproducible:
everytime

Steps to Reproduce:
1. select kernel 4.19.12-301 at boot
2. screen blanks

Actual results:
blank screen

Expected results:
plymouth boot screen should be shown, followed by GDM

Additional info:
kernel-4.19.10-300.fc29.x86_64 also failed to boot

Comment 1 Hans de Goede 2019-01-03 12:25:58 UTC
Sometimes dracut decides to put the new initramfs in a weird place because of BLS support, please do:

ls -l /boot/initramfs-4.19.12-301.fc29.x86_64.img

And verify that the timestamp matches with when you run the dracut command, to force dracut to write the right file do:

sudo dracut -f /boot/initramfs-4.19.12-301.fc29.x86_64.img 4.19.12-301.fc29.x86_64

Comment 2 nbogiatzoglou 2019-01-03 18:59:01 UTC
Unfortunately, regenerating the initramfs with the provided command doesn't make a difference.

An updated kernel package, kernel-4.19.13-300.fc29.x86_64, has become available but it also doesn't affect the issue.

Every 4.19 kernel I have tried fails to boot every time. 4.18 kernels boot sometimes. I had to reboot 5 times to be able to continue to the  plymouth boot screen with kernel kernel-4.18.16-300.

Comment 3 Hans de Goede 2019-01-03 21:14:35 UTC
(In reply to nbogiatzoglou from comment #2)
> Unfortunately, regenerating the initramfs with the provided command doesn't
> make a difference.

Too bad. Still I think this has something to do with recent firmware loading changes in the amdgpu driver.

You may want to add yourself to the Cc of bug 1663204, where a similar issue is being discussed.

Comment 4 nbogiatzoglou 2019-01-04 04:26:08 UTC
Could you please check the relevant bug number you mentioned?

Comment 5 Hans de Goede 2019-01-04 10:02:15 UTC
(In reply to nbogiatzoglou from comment #4)
> Could you please check the relevant bug number you mentioned?

You are right I somehow mentioned the wrong bug number, the bug I was trying to reference is bug 1663126.

Comment 6 nbogiatzoglou 2019-01-04 15:11:44 UTC
Rereading my comment, I realized that it's hard to understand what I meant :)

The bug number that is mentioned in Comment 3 is the same as this bug, could you please provide the correct one? Thanks!

Comment 7 Hans de Goede 2019-01-04 15:53:30 UTC
Yes I understood already but I accidentally made my reply comment private, this is fixed now. The bug I was trying to refer to is bug 1663126.

Comment 8 nbogiatzoglou 2019-01-04 18:50:45 UTC
The two bugs seem similar but, in my case, initramfs contains the firmware files:

sudo lsinitrd  -k 4.18.16-300.fc29.x86_64 | grep -i raven
-rw-r--r--   1 root     root        37376 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_asd.bin
-rw-r--r--   1 root     root         9344 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_ce.bin
-rw-r--r--   1 root     root          316 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_gpu_info.bin
-rw-r--r--   1 root     root        17536 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_me.bin
-rw-r--r--   2 root     root       268048 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_mec2.bin
-rw-r--r--   2 root     root            0 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_mec.bin
-rw-r--r--   1 root     root        21632 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_pfp.bin
-rw-r--r--   1 root     root        39036 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_rlc.bin
-rw-r--r--   1 root     root        17408 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_sdma.bin
-rw-r--r--   1 root     root       341728 Jul 26 14:15 usr/lib/firmware/amdgpu/raven_vcn.bin

sudo lsinitrd  -k 4.19.12-301.fc29.x86_64 | grep -i raven
-rw-r--r--   1 root     root        49664 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_asd.bin
-rw-r--r--   1 root     root         9344 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_ce.bin
-rw-r--r--   1 root     root          316 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_gpu_info.bin
-rw-r--r--   1 root     root        17536 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_me.bin
-rw-r--r--   2 root     root       268048 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_mec2.bin
-rw-r--r--   2 root     root            0 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_mec.bin
-rw-r--r--   1 root     root        21632 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_pfp.bin
-rw-r--r--   1 root     root        39036 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_rlc.bin
-rw-r--r--   1 root     root        17408 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_sdma.bin
-rw-r--r--   1 root     root       341728 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_vcn.bin

sudo lsinitrd  -k 4.19.13-300.fc29.x86_64 | grep -i raven
-rw-r--r--   1 root     root        49664 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_asd.bin
-rw-r--r--   1 root     root         9344 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_ce.bin
-rw-r--r--   1 root     root          316 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_gpu_info.bin
-rw-r--r--   1 root     root        17536 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_me.bin
-rw-r--r--   2 root     root       268048 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_mec2.bin
-rw-r--r--   2 root     root            0 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_mec.bin
-rw-r--r--   1 root     root        21632 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_pfp.bin
-rw-r--r--   1 root     root        39036 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_rlc.bin
-rw-r--r--   1 root     root        17408 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_sdma.bin
-rw-r--r--   1 root     root       341728 Dec  4 12:27 usr/lib/firmware/amdgpu/raven_vcn.bin

Comment 9 Justin M. Forbes 2019-01-29 16:13:43 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 4.20.5-200.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 10 nbogiatzoglou 2019-01-30 06:41:19 UTC
You can close the bug, the new 4.20.5-200.fc29 kernel has solved the problem.

Thanks

Comment 11 Justin M. Forbes 2019-01-30 15:10:49 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.