Bug 1663259 - vdo ansible module --readCache option should be removed
Summary: vdo ansible module --readCache option should be removed
Keywords:
Status: CLOSED DUPLICATE of bug 1669534
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: vdo
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Bryan Gurney
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On: 1682564
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-03 15:11 UTC by Jakub Krysl
Modified: 2019-06-11 17:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 18:00:18 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Jakub Krysl 2019-01-03 15:11:50 UTC
Description of problem:

VDO ansible module should have no mentions of --readCache. For more details on --readCache removal see BZ 1639792.

Version-Release number of selected component (if applicable):
vdo-6.2.0.293-10.el8.x86_64

How reproducible:
100%

Steps to Reproduce:
1.grep -R readCache /usr/share/doc/vdo
2.grep -R "read cache" /usr/share/doc/vdo

Actual results:
# grep -R readCache /usr/share/doc/vdo
/usr/share/doc/vdo/examples/ansible/vdo.py:        options.append("--readCache=enabled")
/usr/share/doc/vdo/examples/ansible/vdo.py:        options.append("--readCacheSize=" + params['readcachesize'])
# grep -R "read cache" /usr/share/doc/vdo
/usr/share/doc/vdo/examples/ansible/vdo.py:            - Enables or disables the read cache.  The default is
/usr/share/doc/vdo/examples/ansible/vdo.py:              'disabled'.  Choosing 'enabled' enables a read cache
/usr/share/doc/vdo/examples/ansible/vdo.py:            - Specifies the extra VDO device read cache size in
/usr/share/doc/vdo/examples/ansible/vdo.py:              with 4 bio threads will have a read cache memory usage
/usr/share/doc/vdo/examples/ansible/vdo.py:              overhead of 4.5 MB per 1 MB of read cache specified).

Expected results:
nothing

Additional info:

Comment 1 Bryan Gurney 2019-01-03 16:30:46 UTC
The design of the VDO Ansible module is to be able to work with multiple versions of VDO, which may remove non-required options.

In the case of the "--readCache" and "--readCacheSize" options, if the playbook specifies these options, VDO on RHEL 8 would return the error "vdo create: error: unrecognized arguments", with the arguments used.  This would be an indication to the user that the version of VDO does not support the "--readCache" or "--readCacheSize" options.

The above would be a more consistent and informative failure mode for the user

The VDO Ansible module has been a part of upstream Ansible since version 2.5.

Comment 4 Bryan Gurney 2019-03-18 18:00:18 UTC
BZ 1669534 calls for the removal of the "vdo.py" Ansible module from the VDO package, which satisfies the removal of the "--readCache" option as stated above.

Closing this BZ as a duplicate.

*** This bug has been marked as a duplicate of bug 1669534 ***


Note You need to log in before you can comment on or make changes to this bug.