Bug 1669534 - Remove Ansible module from VDO package
Summary: Remove Ansible module from VDO package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: vdo
Version: 8.1
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: 8.0
Assignee: Bryan Gurney
QA Contact: vdo-qe
Marek Suchánek
URL:
Whiteboard:
: 1663259 (view as bug list)
Depends On: 1682564
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-25 15:08 UTC by Dennis Keefe
Modified: 2019-11-05 22:12 UTC (History)
3 users (show)

Fixed In Version: 6.2.1.20
Doc Type: Enhancement
Doc Text:
.The VDO Ansible module has been moved to Ansible packages Previously, the VDO Ansible module was provided by the `vdo` RPM package. Starting with this release, the module is provided by the `ansible` package instead. The original location of the VDO Ansible module file was: ---- /usr/share/doc/vdo/examples/ansible/vdo.py ---- The new location of the file is: ---- /usr/lib/python3.6/site-packages/ansible/modules/system/vdo.py ---- The `vdo` package continues to distribute Ansible playbooks. For more information on Ansible, see link:http://docs.ansible.com/[].
Clone Of:
Environment:
Last Closed: 2019-11-05 22:12:27 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3548 None None None 2019-11-05 22:12:42 UTC

Description Dennis Keefe 2019-01-25 15:08:34 UTC
Description of problem:
VDO Ansible module is now in Ansible RPM.  Users should use the VDO Ansible module from the Ansible RPM instead of from the VDO RPM.  The VDO Ansible module should be removed from VDO's RPM  

files to be removed:
/usr/share/doc/vdo/examples/ansible/vdo.py
/usr/share/doc/vdo/examples/ansible/vdo.pyc
/usr/share/doc/vdo/examples/ansible/vdo.pyo

The Ansible directory also has playbooks, which are useful, so these can stay in the directory as a reference.


Files to keep:
/usr/share/doc/vdo/examples/ansible/test_vdocreate.yml
/usr/share/doc/vdo/examples/ansible/test_vdocreate_alloptions.yml
/usr/share/doc/vdo/examples/ansible/test_vdoremove.yml

Comment 1 Bryan Gurney 2019-03-18 17:56:01 UTC
The README.txt file will remain in the directory, with the following header:

----
This directory contains example playbooks for the "vdo" module in Ansible,
which can be used to create and remove VDO volumes, modify configuration
options, and start and stop VDO volumes.

The Ansible "vdo" module can be found in Ansible, version 2.5 or greater.
General information on Ansible can be found at http://docs.ansible.com/
----

Comment 2 Bryan Gurney 2019-03-18 18:00:18 UTC
*** Bug 1663259 has been marked as a duplicate of this bug. ***

Comment 10 Jakub Krysl 2019-07-25 12:48:44 UTC
vdo-6.2.1.102-11.el8.x86_64

# rpm -ql vdo | grep ansible
/usr/share/doc/vdo/examples/ansible
/usr/share/doc/vdo/examples/ansible/README.txt
/usr/share/doc/vdo/examples/ansible/test_vdocreate.yml
/usr/share/doc/vdo/examples/ansible/test_vdocreate_alloptions.yml
/usr/share/doc/vdo/examples/ansible/test_vdoremove.yml

# cat /usr/share/doc/vdo/examples/ansible/README.txt
This directory contains example playbooks for the "vdo" module in Ansible,
which can be used to create and remove VDO volumes, modify configuration
options, and start and stop VDO volumes.

The Ansible "vdo" module can be found in Ansible, version 2.5 or greater.
General information on Ansible can be found at http://docs.ansible.com/

To run a playbook:

1. On the control system, set up a passwordless SSH session via the
   "ssh-agent bash" and "ssh-add" commands.

2. Specify the managed hosts and groups by adding them to the
   /etc/ansible/hosts file on the control system.

3. Using the "hosts" value, construct a playbook detailing the desired state
   of the VDO volume.

4. When ready, execute "ansible-playbook <playbook.yml>".  For additional
   diagnostic output, run "ansible-playbook <playbook.yml> -vvvv".


VDO rpm no longer provides any .py ansible modules, only playbooks.

Comment 14 errata-xmlrpc 2019-11-05 22:12:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3548


Note You need to log in before you can comment on or make changes to this bug.