Bug 166397 - Anaconda hangs when trying to access hda
Anaconda hangs when trying to access hda
Status: CLOSED DUPLICATE of bug 170003
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 08:45 EDT by Niclas Axelsson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 17:19:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niclas Axelsson 2005-08-20 08:45:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
When I try to install Fedora Core 4 on my iMac G4 17" Globe, I only come to the step where the installation should format my harddrive (hda). There it stops and shows a errormessage. This is happening everytime.

On the startup, the X server is trying to start, but the installation falls back to textmode everytime. When im in the textinstallation, ill se the message "_X11TransSocketINETConnect() can't get adress for localhost:6001: Temporary failure in name resolution. Cannot open display ":1".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Starts the installation
2. Comes to the step where I partition my disc automaticly
3. The errormessage comes
  

Actual Results:  Ill get this errordescription:

Traceback (most recent call last):
File "/usr/bin/anaconda", line 1160, in ?
 intf.run(id, dispatch)
File "/usr/lib/anaconda/text.py", line 496, in run
 dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
 self.moveStep()
File "/usr/lib/anaconda/partitioning.py", line 54 in partitionObjectsInitialize
 partitions.setFromDisk(diskset)
File "/usr/lib/anaconda/partitions.py", line 108, in setFromDisk
 ptype = partedUtils.get_partition_file_system_type(part)
File "/usr/lib/anaconda/partedUTils.py", line 140, in get_partition_file_system_type
 elif (part.get_flag(parted.PARTITION_BOOT) == 1 and
AttributeError: 'NoneType' object has no attribute 'name'


Additional info:
Comment 1 Paul Nasrat 2005-08-20 10:18:13 EDT
What partitioning scheme are you using?

Can you switch to tty2 and do parted /dev/hda print
Comment 2 Jeremy Katz 2005-11-26 17:19:34 EST

*** This bug has been marked as a duplicate of 170003 ***

Note You need to log in before you can comment on or make changes to this bug.