Bug 170003 - Installer exits abnormally after clicking next in choose partition method screen
Installer exits abnormally after clicking next in choose partition method screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 161877 166397 170004 170005 174231 174334 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 08:51 EDT by Jackson Wright
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 11:42:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Partition Table (618 bytes, text/plain)
2005-10-07 09:31 EDT, Jackson Wright
no flags Details

  None (edit)
Description Jackson Wright 2005-10-06 08:51:07 EDT
Description of problem:
Every time I run the installer and get to the point where I choose whether or 
not to automatically partition the disk or use Disk Druid, I hit automatically 
and hit next, and it crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Turn on Computer.
2.Boot linux from the yaboot thing.
3.run anaconda
4.click through dialog boxes
5.beat hands on desk in frustration
6.reboot...try again
  
Actual results:
My installer exits abnormally after flashing a bug message.

Expected results:
It should continue the installation process.

Additional info:
Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 873 in nextClicked
       self.dispatch.goto.Next()
File "/usr/lib/anaconda/dispatch.py", line 174 in gotoNext
       self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242 in moreStep
       rc=apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/partitioning.py", line 54 in partitionObjectsInitialize
      partitions.setFromDisk(diskset)
File "/usr/lib/anaconda/partitions.py", line 108 in setFromDisk
      ptype=partedUtils.get_partition_file_system_type(part)
File "/usr/lib/anaconda/partedUtils.py", line 140, in 
get_partition_file_system_type
      elif(part.get_flag(partd.PARTITION_BOOT) == 1 and
Attribute Error: "NoneType" object has no attribute 'name'
Comment 1 Chris Lumens 2005-10-06 10:28:05 EDT
*** Bug 170005 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2005-10-06 10:28:15 EDT
*** Bug 170004 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2005-10-06 10:38:50 EDT
I've committed a fix on Rawhide which doesn't help you much right now.  If you
can attach your partition table to this bug report, we can probably come up with
a workaround for you.  You can get your partition table by waiting until the
graphical installer has come up, hitting cmd-alt-f2, and running:

parted /dev/hda p

It's also possible your disk might be /dev/sda, in which case you'd use that
instead.
Comment 4 Jackson Wright 2005-10-07 09:31:28 EDT
Created attachment 119703 [details]
Partition Table

This is what popped up when I followed your instructions.
Comment 5 Jeremy Katz 2005-11-26 17:19:48 EST
*** Bug 166397 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2005-11-26 17:19:48 EST
*** Bug 174231 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2005-11-26 17:21:26 EST
*** Bug 161877 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2005-11-30 22:17:19 EST
*** Bug 174334 has been marked as a duplicate of this bug. ***
Comment 9 Mark Jaffe 2006-02-21 02:44:20 EST
 I am not clear on the method required to attach a printout of the partition table to the bug report. How 
would I get that from an uninstalled system to the one which I use to access the web? I am trying to install 
FC4 to an Apple powerbook G3, which has two HFS+partitions and one ext3fs. Is the installer capable of 
writing to an HFS+ partition? My existing systems cannot read ext3fs.
Comment 10 Paul Nasrat 2006-02-21 10:54:56 EST
Mark - please try the tree here which has a parted update

ftp://zeniv.uk.linux.org/pub/people/dwmw2/fc4-pegasos



Comment 11 Paul Nasrat 2006-02-21 17:39:51 EST
To use GOLD FC-4 media arther than that tree.

http://people.redhat.com/clumens/mac-parted-update/updates.img

Take the updates.img and use dd to write it to a USB key, then use
that with "linux updates" at the yaboot boot: prompt.  

You will need to dd it to the entire device,
so make sure you backup whatever may be on the USB drive first.  
You can dosomething like this:

dd if=updates.img of=/dev/sda

Replace /dev/sda with the name of your USB key drive, though.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=163263
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=159047
Comment 12 Chris Lumens 2006-03-29 11:42:29 EST
Closing based on comments.  Please repoen if you are still experiencing this
problem.

Note You need to log in before you can comment on or make changes to this bug.