Bug 166424 - Please add a "test this configuration" button
Please add a "test this configuration" button
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
bzcl34nup
:
: 178113 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-20 17:31 EDT by Bill Crawford
Modified: 2008-04-07 10:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 10:47:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2005-08-20 17:31:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
When running from a working X setup, it would be nice to be able to test the results of a new config, without having to restart X. Spawing a second server should be an option in this case?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Bill Crawford 2005-08-20 17:36:09 EDT
Oh, and a "make this permanent" button too, of course.
Comment 2 Bill Crawford 2005-08-20 17:52:28 EDT
To expand a little: this is being suggested so that if, for instance, I make a
mistake in setting my monitor details, and the resolution I choose ends up
pushing the monitor out of scan range, I would know more immediately than having
to restart X manually.

In particular, if autodetection has failed, and I have to pick from a list of
monitors, two things can happen:

1) I may pick the wrong monitor, in which case the the wrong h/vsync limits,
coupled with the modes I select, might drive the monitor out of range.
2) I may know the monitor is capable of e.g. 1600x1200x85, but s-c-d doesn't
offer it because it hasn't read the EDID data and isn't aware the monitor claims
to support it.

In the latter case, it would also be helpful if s-c-d would allow me to select
1600x1200, even if it thinks I'm wrong. There could be a command line option
"--allow-dangerous-settings" if necessary :)

And especially in that case, I need to be able to bail out and not change the
xorg.conf if I was wrong :)
Comment 3 Adam Jackson 2006-08-28 16:15:29 EDT
*** Bug 178113 has been marked as a duplicate of this bug. ***
Comment 6 Bug Zapper 2008-04-03 12:18:09 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Bill Crawford 2008-04-07 09:57:55 EDT
I have no idea whether this is even an issue any more; KDE config tools mostly 
seem to have the right confirmation included, and I no longer use s-c-d unless 
I have really screwed up my system ... usually I just tweak a little and have 
a backup or can just reverse the change.
Comment 8 Matěj Cepl 2008-04-07 10:47:17 EDT
I think there is not much future for s-c-d anyway. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.