Bug 1664361 - Gwenview + Exiv2 crash in Pentax camera files
Summary: Gwenview + Exiv2 crash in Pentax camera files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: exiv2
Version: 7.7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1747857
TreeView+ depends on / blocked
 
Reported: 2019-01-08 15:08 UTC by Akemi Yagi
Modified: 2019-09-02 05:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1585514
: 1747857 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:47:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 14882 None None None 2019-01-08 15:08:34 UTC
Red Hat Product Errata RHSA-2019:2101 None None None 2019-08-06 12:47:34 UTC

Description Akemi Yagi 2019-01-08 15:08:35 UTC
+++ This bug was initially created as a clone of Bug #1585514 +++

Description of problem:

The crash is blocked by DNG / PEF or jpg files made with a Pentax camera (DSLR).
A long-standing mistake. I was waiting for Pentax users to have a modified rpm package.
If I managed to draw attention I'm glad!
Thank you!


https://bugs.mageia.org/attachment.cgi?id=9755&action=diff

and

https://github.com/Exiv2/exiv2/issues/201

Comment 2 Jan Grulich 2019-01-08 15:11:21 UTC
This will be fixed in RHEL 7.7 once we update to Exiv 0.27.

Comment 3 Akemi Yagi 2019-01-08 15:16:59 UTC
Any chance it gets fixed in the z-series? As reported in the CentOS bug tracker, the patch from https://github.com/Exiv2/exiv2/commit/5405d61 fixes the issue.

Comment 6 Jan Grulich 2019-01-28 16:08:28 UTC
Fixed with exiv2-0.27.0-1.el7_6.

Comment 10 errata-xmlrpc 2019-08-06 12:47:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:2101

Comment 11 Pablo Greco 2019-08-30 20:07:46 UTC
It appears that this is not fixed after all.
The new package (exiv2-0.27.0-1.el7_6) may have the fix, but gwenview was not rebuilt, so it is still using 026, and since compat-exiv2-026 doesn't have the fix, gwenview still crashes.


Note You need to log in before you can comment on or make changes to this bug.