Bug 1747857 - Gwenview + Exiv2 crash in Pentax camera files
Summary: Gwenview + Exiv2 crash in Pentax camera files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: compat-exiv2-026
Version: 7.7
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: 7.9
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1664361
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-02 05:00 UTC by Jan Grulich
Modified: 2020-12-08 08:41 UTC (History)
9 users (show)

Fixed In Version: compat-exiv2-026-0.26-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1664361
Environment:
Last Closed: 2020-12-08 08:41:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:3874 None None None 2020-09-29 19:27:31 UTC

Comment 1 Jan Grulich 2019-09-02 05:01:33 UTC
This issue wasn't actually fixed, because we did not rebuild gwenview against a fixed version of exiv2, but instead we created a compat package which doesn't have the fix. There is a simple fix that can be backported which should fix this issue.


Note You need to log in before you can comment on or make changes to this bug.