Bug 16644 - samba's log files are confused
samba's log files are confused
Status: CLOSED DUPLICATE of bug 18455
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
: 27835 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-08-20 14:42 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-07 15:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-08-20 14:42:09 EDT
If you shut down and restart the samba servers, three log files will be
created in /var/log/samba: log.smb, smb.log, and log.nmb.

The first one is created because smbd logs to log.smb before reading the
smb.conf file and realizing that it's actually supposed to be logging to

The second one is a correctly named log file created because of the "log
file = /var/log/samba/%m.log" entry in smb.conf.

The third one is the default log file name for nmbd, and it is problematic
because the pattern in /etc/logrotate.d/samba won't match it so it will
never be rotated.

I assume that the switch from log.smb to smb.log was made because logrotate
goes haywire because of the "/var/log/samba/log.*" pattern matching, trying
to rotate all of the previously rotated log files.  The correct fix for
that problem is probably to fix logrotate, not to screw up samba's log
files and leave things messed up as they are now.

The minimal fix to this problem is to change /etc/logrotate.d/samba so that
it reads "/var/log/samba/*.log /var/log/samba/log.smb
/var/log/samba/log.nmb" instead of just "/var/log/samba/*.log".

Comment 1 Henri Schlereth 2001-01-21 09:39:01 EST
Still exists. Not a show stopper for Depends moving ticket to Beta 2 (Florence)
Comment 2 Bill Nottingham 2001-02-15 15:44:26 EST

*** This bug has been marked as a duplicate of 27835 ***
Comment 3 Bill Nottingham 2001-02-16 12:37:17 EST
*** Bug 27835 has been marked as a duplicate of this bug. ***
Comment 4 Trond Eivind Glomsrxd 2001-06-21 20:15:31 EDT

*** This bug has been marked as a duplicate of 18455 ***

Note You need to log in before you can comment on or make changes to this bug.