Bug 1664588 - [CinderLib] - Adding managed storage via UI/REST fails
Summary: [CinderLib] - Adding managed storage via UI/REST fails
Keywords:
Status: CLOSED DUPLICATE of bug 1669047
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ovirt-4.3.1
: ---
Assignee: Tal Nisan
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks: 1539837
TreeView+ depends on / blocked
 
Reported: 2019-01-09 09:01 UTC by Avihai
Modified: 2019-01-31 14:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 14:06:21 UTC
oVirt Team: Storage
rule-engine: ovirt-4.3+


Attachments (Terms of Use)
engine log (201.62 KB, application/gzip)
2019-01-09 09:01 UTC, Avihai
no flags Details
print screen of the issue (141.72 KB, image/png)
2019-01-09 09:05 UTC, Avihai
no flags Details

Description Avihai 2019-01-09 09:01:57 UTC
Created attachment 1519377 [details]
engine log

Description of problem:
try to add managed storage via UI/REST API fails

Version-Release number of selected component (if applicable):
Software Version:4.3.0-0.4.master.20190106162157.gitd96a412.el7


How reproducible:
100%

Steps to Reproduce:
1. Add needed cinder DB and cinder driver as in step described at doc:
https://docs.google.com/document/d/1C2vrAf-Wb_f3cprGdCFC77flmTW1VERKlOm482m-bwg/edit?ts=5c334308#

2.Try to add a managed storage type via UI/API with the parameters from the doc at step 1.

Actual results:
Adding managed storage failes.

Expected results:
Adding managed storage should succeed.

Additional info:

Comment 1 Avihai 2019-01-09 09:05:12 UTC
Created attachment 1519378 [details]
print screen of the issue

Comment 2 Fred Rolland 2019-01-31 13:34:19 UTC
Avihai, is this bug still relevant?
If you have more details on the issue, it will be great.

Comment 3 Avihai 2019-01-31 13:47:08 UTC
Fred, this bug looks related to DB initialization issues that are currently done manually see Bug 1669047. 

As we just saw both DB service and ovirt-engine service has to restart(which was not at the doc from the description) also changing pg_hba.conf file (which it's location changed from in 4.3 u/s vs 4.3 d/s)

You can close-duplicate this bug to that bug as it is the root cause for this bug. (unless you think otherwise)

Engine log:
2019-01-08 16:36:10,777+02 INFO  [org.ovirt.engine.core.common.utils.cinderlib.CinderlibExecutor] (default task-6) [a08aa1fb-61d1-4403-8cc3-a87754e8974c] cinderlib output: (psycopg2.OperationalError) asynchronous connection failed

Comment 4 Fred Rolland 2019-01-31 14:06:21 UTC

*** This bug has been marked as a duplicate of bug 1669047 ***


Note You need to log in before you can comment on or make changes to this bug.