Bug 1669047 - Support creating a cinderlib data-base in the engine-setup process
Summary: Support creating a cinderlib data-base in the engine-setup process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.3.1
: ---
Assignee: Eyal Shenitzky
QA Contact: Avihai
URL:
Whiteboard:
: 1664588 (view as bug list)
Depends On:
Blocks: 1539837
TreeView+ depends on / blocked
 
Reported: 2019-01-24 08:13 UTC by Eyal Shenitzky
Modified: 2019-04-11 13:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In order to create and use a Managed block storage domain, a new database must be created that is accessible by cinderlib. In this release, a new database can be created during the engine-setup process, using the same procedures described in the documentation for "Configuring the Red Hat Virtualization Manager".
Clone Of:
Environment:
Last Closed: 2019-03-13 16:40:29 UTC
oVirt Team: Storage
Embargoed:
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 97106 0 master MERGED packaging: setup: add CinderLib DB 2020-11-06 18:44:47 UTC
oVirt gerrit 97394 0 master MERGED core: use configured cinderlib database parameters in cinderlibExecutor 2020-11-06 18:44:46 UTC
oVirt gerrit 97466 0 master MERGED core: support managed block operation only if cinderlib DB configured 2020-11-06 18:44:46 UTC
oVirt gerrit 97726 0 master MERGED packaging: setup: Cinderlib fixes 2020-11-06 18:44:47 UTC

Description Eyal Shenitzky 2019-01-24 08:13:30 UTC
Description of problem:

We need to add the option to add the database required by cinderlib in the engine-setup installation process.

Currently, the user should add this DB manually.

Version-Release number of selected component (if applicable):
master-4.3

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Fred Rolland 2019-01-31 14:06:21 UTC
*** Bug 1664588 has been marked as a duplicate of this bug. ***

Comment 4 Avihai 2019-03-06 08:03:15 UTC
Verified in ovirt-engine Software Version:4.3.1.1-0.1.el7

Comment 6 Sandro Bonazzola 2019-03-13 16:40:29 UTC
This bugzilla is included in oVirt 4.3.1 release, published on February 28th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.