Bug 1665238 - openshift-cluster-node-tuning-operator does not exist when using OCP images for the installer
Summary: openshift-cluster-node-tuning-operator does not exist when using OCP images f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Tim Bielawa
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-10 18:35 UTC by Hongkai Liu
Modified: 2019-06-04 10:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:48 UTC

Description Hongkai Liu 2019-01-10 18:35:15 UTC
Description of problem:

Version-Release number of the following components:
$ openshift-install version
openshift-install v0.9.1

$ oc get clusterversion version
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-08-152529   True        False         3h        Cluster version is 4.0.0-0.nightly-2019-01-08-152529



How reproducible: always

Steps to Reproduce:
1. export _OPENSHIFT_INSTALL_RELEASE_IMAGE_OVERRIDE=registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-01-08-152529
2. Add an auth for "registry.svc.ci.openshift.org" into the pull secret.
3. openshift-install create cluster --dir=./20190110

Actual results:
$ oc project openshift-cluster-node-tuning-operator
error: A project named "openshift-cluster-node-tuning-operator" does not exist on "https://hongkliu-api.devcluster.openshift.com:6443".
Your projects are:
* default
* kube-public
* kube-system
* openshift
* openshift-apiserver
* openshift-apiserver-operator
* openshift-cluster-api
* openshift-cluster-kube-scheduler-operator
* openshift-cluster-machine-approver
* openshift-cluster-network-operator
* openshift-cluster-openshift-controller-manager-operator
* openshift-cluster-samples-operator
* openshift-cluster-version
* openshift-console
* openshift-controller-manager
* openshift-core-operators
* openshift-csi-operator
* openshift-dns
* openshift-dns-operator
* openshift-infra
* openshift-ingress
* openshift-ingress-operator
* openshift-kube-apiserver
* openshift-kube-apiserver-operator
* openshift-kube-controller-manager
* openshift-kube-controller-manager-operator
* openshift-kube-scheduler
* openshift-machine-config-operator
* openshift-monitoring
* openshift-node
* openshift-operator-lifecycle-manager
* openshift-operators
* openshift-osin
* openshift-sdn
* openshift-service-cert-signer


Expected results:
project openshift-cluster-node-tuning-operator exists and its components are running.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 W. Trevor King 2019-01-11 19:12:28 UTC
This should be assigned to the Release component [1].

[1]: https://bugzilla.redhat.com/show_bug.cgi?id=1664984#c4

Comment 6 Hongkai Liu 2019-01-15 19:18:43 UTC
Not sure if it is expected:

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-15-064327   True        False         35m       Cluster version is 4.0.0-0.nightly-2019-01-15-064327
$ oc get clusterversion version -o json | jq .status.desired
{
  "payload": "registry.svc.ci.openshift.org/ocp/release@sha256:584f8f454184f6ece5679bf8103560f450e557d1d98711a4540d822c255fbeee",
  "version": "4.0.0-0.nightly-2019-01-15-064327"
}
$ oc project
Using project "openshift-cluster-node-tuning-operator" on server "https://hongkliu-api.qe.devcluster.openshift.com:6443".
$ oc get all
NAME                                                READY     STATUS    RESTARTS   AGE
pod/cluster-node-tuning-operator-7cc69776f4-pftpg   1/1       Running   0          40m
pod/tuned-5sss6                                     1/1       Running   0          40m
pod/tuned-68q8b                                     1/1       Running   0          40m
pod/tuned-6wb4d                                     1/1       Running   0          38m
pod/tuned-plwxh                                     1/1       Running   0          38m
pod/tuned-znjr4                                     1/1       Running   0          38m
pod/tuned-zq5c5                                     1/1       Running   0          40m

NAME                   DESIRED   CURRENT   READY     UP-TO-DATE   AVAILABLE   NODE SELECTOR                 AGE
daemonset.apps/tuned   6         6         6         6            6           beta.kubernetes.io/os=linux   40m

NAME                                           DESIRED   CURRENT   UP-TO-DATE   AVAILABLE   AGE
deployment.apps/cluster-node-tuning-operator   1         1         1            1           40m

NAME                                                      DESIRED   CURRENT   READY     AGE
replicaset.apps/cluster-node-tuning-operator-7cc69776f4   1         1         1         40m


I will test again when it moves to ON_QA.

Comment 7 jmencak 2019-01-16 07:16:59 UTC
(In reply to Hongkai Liu from comment #6)
> Not sure if it is expected:
> 
> $ oc get clusterversion
> NAME      VERSION                             AVAILABLE   PROGRESSING  
> SINCE     STATUS
> version   4.0.0-0.nightly-2019-01-15-064327   True        False         35m 
> Cluster version is 4.0.0-0.nightly-2019-01-15-064327
> $ oc get clusterversion version -o json | jq .status.desired
> {
>   "payload":
> "registry.svc.ci.openshift.org/ocp/release@sha256:
> 584f8f454184f6ece5679bf8103560f450e557d1d98711a4540d822c255fbeee",
>   "version": "4.0.0-0.nightly-2019-01-15-064327"
> }
> $ oc project
> Using project "openshift-cluster-node-tuning-operator" on server
> "https://hongkliu-api.qe.devcluster.openshift.com:6443".
> $ oc get all
> NAME                                                READY     STATUS   
> RESTARTS   AGE
> pod/cluster-node-tuning-operator-7cc69776f4-pftpg   1/1       Running   0   
> 40m
> pod/tuned-5sss6                                     1/1       Running   0   
> 40m
> pod/tuned-68q8b                                     1/1       Running   0   
> 40m
> pod/tuned-6wb4d                                     1/1       Running   0   
> 38m
> pod/tuned-plwxh                                     1/1       Running   0   
> 38m
> pod/tuned-znjr4                                     1/1       Running   0   
> 38m
> pod/tuned-zq5c5                                     1/1       Running   0   
> 40m
> 
> NAME                   DESIRED   CURRENT   READY     UP-TO-DATE   AVAILABLE 
> NODE SELECTOR                 AGE
> daemonset.apps/tuned   6         6         6         6            6         
> beta.kubernetes.io/os=linux   40m
> 
> NAME                                           DESIRED   CURRENT  
> UP-TO-DATE   AVAILABLE   AGE
> deployment.apps/cluster-node-tuning-operator   1         1         1        
> 1           40m
> 
> NAME                                                      DESIRED   CURRENT 
> READY     AGE
> replicaset.apps/cluster-node-tuning-operator-7cc69776f4   1         1       
> 1         40m
> 
> 
> I will test again when it moves to ON_QA.

If it is a 6 node OCP cluster, this looks good to me.  Is there something you didn't expect?

Comment 8 Hongkai Liu 2019-01-16 13:44:28 UTC
Ah, no. All good.
I asked that because usually I would see Modified then see a fix. ^_^
I will test it again today. Thanks.

Comment 9 Hongkai Liu 2019-01-16 18:49:17 UTC
$ oc get clusterversion
NAME      VERSION     AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.1   True        False         1h        Cluster version is 4.0.0-0.1
$ oc get all -n openshift-cluster-node-tuning-operator
NAME                                                READY     STATUS    RESTARTS   AGE
pod/cluster-node-tuning-operator-6577b57d74-wktjj   1/1       Running   0          1h
pod/tuned-27g57                                     1/1       Running   0          1h
pod/tuned-g9g85                                     1/1       Running   0          1h
pod/tuned-ggchv                                     1/1       Running   0          1h
pod/tuned-kf7qd                                     1/1       Running   0          1h
pod/tuned-p8nkr                                     1/1       Running   0          1h
pod/tuned-r769k                                     1/1       Running   0          1h

NAME                   DESIRED   CURRENT   READY     UP-TO-DATE   AVAILABLE   NODE SELECTOR                 AGE
daemonset.apps/tuned   6         6         6         6            6           beta.kubernetes.io/os=linux   1h

NAME                                           DESIRED   CURRENT   UP-TO-DATE   AVAILABLE   AGE
deployment.apps/cluster-node-tuning-operator   1         1         1            1           1h

NAME                                                      DESIRED   CURRENT   READY     AGE
replicaset.apps/cluster-node-tuning-operator-6577b57d74   1         1         1         1h

Comment 12 errata-xmlrpc 2019-06-04 10:41:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.