Bug 1665521 - GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed
Summary: GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ernestas Kulik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1665676 1665862 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-11 16:01 UTC by Christian Labisch
Modified: 2019-01-29 17:46 UTC (History)
20 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-16 02:19:37 UTC


Attachments (Terms of Use)

Description Christian Labisch 2019-01-11 16:01:56 UTC
After upgrading the abrt packages to version 2.11.1-2.fc29 today, the error
message "GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed"
is reported in journalctl and, a "strange folder" gets created in the /home
directory - this happens after every system reboot - here are the details :

$ journalctl | grep GLib-CRITICAL
Jan 11 15:10:41 gnome-session[1877]: gnome-session-binary[1877]: GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed
Jan 11 15:10:41 gnome-session-binary[1877]: GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed

$ ls -l /home/cl
total 36
drwxr-xr-x. 3 cl cl 4096 11. Jan 15:10 ''$'\340\017'';'

$ ls -l /home/cl/''$'\340\017'';'
total 4
drwxr-xr-x. 2 cl cl 4096 11. Jan 15:10 '>V'

$ ls -l /home/cl/''$'\340\017'';'/'>V'
total 0

Comment 1 Christian Labisch 2019-01-11 17:20:09 UTC
Additional information : In order to verify that abrt indeed is the root cause,
I've removed all abrt packages - after restart of the system the issue is gone.

Comment 2 Matej Marušák 2019-01-11 19:03:59 UTC
I checked it and I am able to reproduce it. I did a bisect and found out, that it starts to happen with commit https://github.com/abrt/abrt/commit/722ba44fa3d0665d68fecdade7b816d7c1a2d484
Assigning author of the commit

Comment 3 Ernestas Kulik 2019-01-12 09:55:47 UTC
The critical is unrelated and comes from somewhere else.

Comment 4 Matej Marušák 2019-01-12 11:27:33 UTC
Upstream fix https://github.com/abrt/abrt/pull/1354

Comment 5 Christian Labisch 2019-01-12 12:08:30 UTC
There is a (new) file located in /etc/xdg/autostart which seems to be responsible for the problem.
The file (from abrt) is linked to /usr/share/applications/org.freedesktop.problems.applet.desktop.
Removing this file solves the problem - after restart no journalctl message and no strange folder.

$ sudo locate org.freedesktop.problems.applet.desktop
/etc/xdg/autostart/org.freedesktop.problems.applet.desktop
/usr/share/applications/org.freedesktop.problems.applet.desktop

$ sudo rm /etc/xdg/autostart/org.freedesktop.problems.applet.desktop

Comment 6 Axel Sommerfeldt 2019-01-12 15:39:50 UTC
Same problem here since yesterdays update (F29 Workstation), renaming /usr/share/applications/org.freedesktop.problems.applet.desktop works as a work-around.

Comment 7 Christian Labisch 2019-01-12 15:49:29 UTC
(In reply to Axel Sommerfeldt from comment #6)
> Same problem here since yesterdays update (F29 Workstation), renaming
> /usr/share/applications/org.freedesktop.problems.applet.desktop works as a
> work-around.

Hi Axel, the renaming should remove the ABRT desktop icon from the GNOME GUI dash.
Better remove the /etc/xdg/autostart/org.freedesktop.problems.applet.desktop file.

Comment 8 Ernestas Kulik 2019-01-12 16:41:00 UTC
The critical should go away if we stop using a symlink for the desktop file in /etc/xdg/autostart. The “DBusActivatable=true” line is what seems to be causing it, even though I can’t explain how just yet. Until then, it’s perfectly fine to ignore it.

Comment 9 saif1988 2019-01-12 19:36:15 UTC
Confirming it happened to me too. I was completely puzzled.

For me, deleting the file mentioning above at /etc/xdg/autostart  fixed it. I realized it was it because it started happening when I installed gnome desktop on my KDE setup.

Comment 10 Eric Work 2019-01-13 07:06:04 UTC
*** Bug 1665676 has been marked as a duplicate of this bug. ***

Comment 11 chiguy1256 2019-01-13 13:39:18 UTC
I reinstalled Fedora 29 xfce yesterday and noticed the same thing.  I will try the suggested solution and see how it goes.  Thanks.

Comment 12 chiguy1256 2019-01-13 14:01:54 UTC
I have tried the suggestion of removing the file and I deleted the weird folders and restarted my laptop.  No more weird folders.  Thank you.

Comment 13 Christian Labisch 2019-01-13 14:14:27 UTC
(In reply to chiguy1256 from comment #12)
> I have tried the suggestion of removing the file and I deleted the weird
> folders and restarted my laptop.  No more weird folders.  Thank you.

You're welcome ! Let's hope that it's fixed completely in the next version.
It's not only the folders, it's also about the error message in journalctl.
Without the symbolic link file in /etc/xdg/autostart, both issues are gone.

Comment 14 Ernestas Kulik 2019-01-13 14:23:05 UTC
(In reply to Christian Labisch from comment #13)
> (In reply to chiguy1256 from comment #12)
> > I have tried the suggestion of removing the file and I deleted the weird
> > folders and restarted my laptop.  No more weird folders.  Thank you.
> 
> You're welcome ! Let's hope that it's fixed completely in the next version.
> It's not only the folders, it's also about the error message in journalctl.
> Without the symbolic link file in /etc/xdg/autostart, both issues are gone.

The workaround has been mentioned enough times.

https://gitlab.gnome.org/GNOME/gnome-session/issues/14 for the critical.

Comment 15 Fedora Update System 2019-01-14 08:26:02 UTC
abrt-2.11.1-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5c308118f

Comment 16 Kamil Dudka 2019-01-14 10:52:24 UTC
*** Bug 1665862 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2019-01-15 02:23:25 UTC
abrt-2.11.1-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b5c308118f

Comment 18 Fedora Update System 2019-01-16 02:19:37 UTC
abrt-2.11.1-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Christian Labisch 2019-01-16 08:39:05 UTC
(In reply to Ernestas Kulik from comment #14)
> (In reply to Christian Labisch from comment #13)
> > (In reply to chiguy1256 from comment #12)
> > > I have tried the suggestion of removing the file and I deleted the weird
> > > folders and restarted my laptop.  No more weird folders.  Thank you.
> > 
> > You're welcome ! Let's hope that it's fixed completely in the next version.
> > It's not only the folders, it's also about the error message in journalctl.
> > Without the symbolic link file in /etc/xdg/autostart, both issues are gone.
> 
> The workaround has been mentioned enough times.
> 
> https://gitlab.gnome.org/GNOME/gnome-session/issues/14 for the critical.

Hi Ernestas, "The workaround has been mentioned enough times" ... well, seems not.
The strange folders don't get created any more, but what about the error message ?
I have updated abrt to version 2.11.1-3.fc29 (from the stable updates repository).
I still have to remove /etc/xdg/autostart/org.freedesktop.problems.applet.desktop.
Otherwise error GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0' failed.

Comment 20 Ernestas Kulik 2019-01-16 08:41:06 UTC
(In reply to Christian Labisch from comment #19)
> Hi Ernestas, "The workaround has been mentioned enough times" ... well,
> seems not.
> The strange folders don't get created any more, but what about the error
> message ?
> I have updated abrt to version 2.11.1-3.fc29 (from the stable updates
> repository).
> I still have to remove
> /etc/xdg/autostart/org.freedesktop.problems.applet.desktop.
> Otherwise error GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0'
> failed.

Does the critical actually affect you or is it just an annoyance? I already said that it’s harmless, so I’d rather see if it can be fixed at the source (which is gnome-session) before resorting to working around in abrt.

Comment 21 Christian Labisch 2019-01-16 09:02:13 UTC
(In reply to Ernestas Kulik from comment #20)
> (In reply to Christian Labisch from comment #19)
> > Hi Ernestas, "The workaround has been mentioned enough times" ... well,
> > seems not.
> > The strange folders don't get created any more, but what about the error
> > message ?
> > I have updated abrt to version 2.11.1-3.fc29 (from the stable updates
> > repository).
> > I still have to remove
> > /etc/xdg/autostart/org.freedesktop.problems.applet.desktop.
> > Otherwise error GLib-CRITICAL: g_child_watch_add_full: assertion 'pid > 0'
> > failed.
> 
> Does the critical actually affect you or is it just an annoyance? I already
> said that it’s harmless, so I’d rather see if it can be fixed at the source
> (which is gnome-session) before resorting to working around in abrt.

No affection, just an "annoyance" ... it's okay to fix it in gnome-session.
As I said, I have removed the symlink file to get rid of the error message.


Note You need to log in before you can comment on or make changes to this bug.