Bug 16665 - Have sound load *outside* rc.sysinit to prevent non-bootable system
Have sound load *outside* rc.sysinit to prevent non-bootable system
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
: 21281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-21 01:44 EDT by Joshua Buysse
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-12 03:07:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Buysse 2000-08-21 01:44:34 EDT
Sound loading during rc.sysinit is a bad idea, see bug 16663 for a good 
reason why.  If the sound modules are buggered, user can't even get to 
single-user without deep magic.

Maybe something like /etc/init.d/sound, loading early in multi-user but 
never in single-user?
Comment 1 Bill Nottingham 2000-12-12 03:07:22 EST
*** Bug 21281 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2000-12-12 03:08:27 EST
As of initscripts-5.53-1, sound modules will only be loaded
if persistent DMA buffers are needed. I'm still considering
putting this other places.

Note You need to log in before you can comment on or make changes to this bug.