Bug 166742 - e-d-s cannot access addressbooks
Summary: e-d-s cannot access addressbooks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
: 166782 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-08-25 05:20 UTC by Michel Alexandre Salim
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 1.3.8-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 23:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michel Alexandre Salim 2005-08-25 05:20:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050815 Epiphany/1.7.5

Description of problem:
I just noticed that after upgrading to evo and e-d-s 1.3.8, I no longer get address auto-completion in Evolution. When I clicked on Contacts I just realized that the problem was even worse: on selecting each of the address books I get a message like the following (for the default 'Personal' addressbook):

   Unable to open addressbook

   Error loading addressbook.

   We were unable to open this addressbook.  Please check that the path
   /home/michel/.evolution/addressbook/local/system exists and that you have
   permission to access it.

Reverting evolution to 2.3.7-3 does not solve the problem, but reverting e-d-s to 2.3.7-2 does.

Version-Release number of selected component (if applicable):
evolution-data-server-1.3.8-3

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to latest evolution*
2. Try opening address book
3. 
  

Actual Results:  Address books cannot be opened in 2.3.8. Tried this using a fresh ~/.evolution directory on a test user account, same result. Reverting to 2.3.7 helps.

Expected Results:  Address books should work in 2.3.8 like they do in 2.3.7

Additional info:

Comment 1 Lars G 2005-08-25 12:23:49 UTC
same here.

Comment 2 Mickey Hill 2005-08-25 15:18:37 UTC
same here.

Comment 3 Dave Malcolm 2005-08-25 21:15:59 UTC
*** Bug 166782 has been marked as a duplicate of this bug. ***

Comment 4 Rodd Clarkson 2005-08-26 03:24:17 UTC
I cc'ed in earlier, but I guess I'll same here too since I have something to add.

I also can't add contacts by right clicking the email address.

Steps to reproduce.

1. open and email and right click an email address.
2. select 'Add to addressbook'
3. in the resulting dialog, select 'Edit Full'

no dialog appears.

I'm guessing that this is also related to this bug.  If it isn't I'll file it as
a seperate bug.

Comment 5 Dave Malcolm 2005-08-26 03:42:14 UTC
Re comment #4: looks like another symptom of this bug

I'm working on this now; hopefully should be fixed in tomorrow's rawhide...

Comment 6 Dave Malcolm 2005-08-26 04:47:25 UTC
OK - I've built a fix as evolution-data-server-1.3.8-4; this should land in
rawhide tomorrow,

It seems to fix it for me; please test this and confirm it fixes it for you. 
Thanks.

Comment 7 Michel Alexandre Salim 2005-09-05 23:30:27 UTC
It does indeed work, thanks.


Note You need to log in before you can comment on or make changes to this bug.