This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 166751 - installation from usb cd fails.
installation from usb cd fails.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2005-08-25 06:06 EDT by Troels Arvin
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-19 04:05:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Troels Arvin 2005-08-25 06:06:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050721 CentOS/1.0.6-1.4.1.centos4 Firefox/1.0.6

Description of problem:
When trying to install FC4 on a "LEX NEO - 1GHz" system, the installer fails after the installation medium test. On terminal three, the last lines are:

Loading SELinux policy from /mnt/runtime/etc/selinux/targeted/policy/policy.19.
getting ready to spawn shell now

On the main terminal, I get blue screen of death with a lot of output, including "Oops: 0000 [#1]", a call trace, etc. I can copy the text off the screen manually, if needed.

The "Lex NEO" system contains a SV823A-4U10L motherboard with a Via C3-2 ("Nehemiah") CPU. RAM (DDR PC2700, 333 MHz, 512 MB) tested OK with memtest86. More motherboard info: http://www.lex.com.tw:8080/index1.htm

The same problem appears with CentOS 4.1's installer, by the way.

I carried on this way: Booted off Knoppix 4.0 (which has no problem booting on the machine) and copied a clone of an existing i686 uniprocessor CentOS 4.1 installation to the host and grubbed it. After rebooting, everything runs fine.

Hypothesis:
I suspect that the problem is related to bug# 120685. Is the installer's kernel different from the kernel being installed on the PC? - In that case, the installer's kernel may have to be built with less aggressive CPU optimizations.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attach USB-connected DVD to PC.
2. Boot off FC4 installation DVD.
3. Proceeed by choosing language, etc. After installation medium check: BANG.
  

Additional info:
Comment 1 Dave Jones 2005-08-26 05:26:51 EDT
"I can copy the text off the screen manually, if needed."

Please do. It's key to finding out where we crashed.
If needbe, and you have one, use a digital camera to take a picture.
Another trick that may be useful - booting with vga=791 gets more lines of text
on the screen.

The installer kernel is exactly the same as the final kernel that gets installed
btw.
Comment 2 Troels Arvin 2005-08-26 07:56:27 EDT
Here are three photos of the same screen:
http://dna.genome.kvl.dk/people/troels/public/bugzilla/redhat/166751/oops-shots/
The photographs were obtained after a "linux ide=nodma vga=791" boot on an FC4
installation DVD.

(If I leave out the "ide=nodma" part, nothing changes. ide=nodma is just
something I've gotten used to when booting on installation CDs.)

By the way: I install from an USB-connected DVD. Thus, during the first part of
the installation, I choose
  Local CDROM ->
   Select driver ->
    USB Mass Storage driver for Linux (usb-storage)

Oh, and, by the way: I've just tried using the installation DVD in another host
with less exotic hardware (some kind of Pentium III machine, I believe). On that
machine, the installation process was able to proceed much further (before I
interruped it, because I didn't really want to install FC4 on that host).
Comment 3 Dave Jones 2005-09-12 01:51:01 EDT
This looks familiar, though I don't have the other bugzilla # to hand.

Pete, any magic usb boot parameters we can pass that may help the situation ?

Comment 4 Pete Zaitcev 2005-09-12 04:42:57 EDT
I don't think this has anything to do with USB. In other words, it's
possible, but unlikely.

I'm sure it should be possible to install from a borrowed CD drive to
verify that (I do not suggest PXE because I'm not sure cramfs is used
then, so it's not close enough scenario).
Comment 5 Dave Jones 2005-09-30 19:53:14 EDT
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.
Comment 6 Dave Jones 2005-11-10 17:02:14 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 7 Dave Jones 2005-11-19 04:05:40 EST
Due to the overhead involved in creating new ISOs (which is what would be
required for fixing bugs seen at installation time that don't have workarounds),
this bug has been closed.

For more information and suggestions, please see bug 169613

Thanks.

Note You need to log in before you can comment on or make changes to this bug.