Bug 166816 - ACPI battery status stops working after a while
Summary: ACPI battery status stops working after a while
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 167013 (view as bug list)
Depends On:
Blocks: FC4Update FCMETA_ACPI 167013
TreeView+ depends on / blocked
 
Reported: 2005-08-26 01:11 UTC by Øyvind Stegard
Modified: 2015-01-04 22:21 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-09-24 02:12:57 UTC


Attachments (Terms of Use)
dmesg at boot time (10.94 KB, text/plain)
2005-08-26 01:20 UTC, Øyvind Stegard
no flags Details
lspci -vv (8.29 KB, text/plain)
2005-08-26 01:21 UTC, Øyvind Stegard
no flags Details
Cleanup for acquire/release of owner_id (7.45 KB, patch)
2005-08-30 13:15 UTC, Alexey Starikovskiy
no flags Details | Diff

Description Øyvind Stegard 2005-08-26 01:11:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; nb-NO; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The ACPI battery status suddenly stops reporting data. 

[oyvind@arwen ~]$ cat /proc/acpi/battery/BAT0/{state,info}
present:                 yes
ERROR: Unable to read battery status
present:                 yes
ERROR: Unable to read battery information

I became aware of this because the battery status applet suddenly reported "No battery present", for no apparent reason. The battery in my laptop works fine, and ACPI battery monitoring has always worked on previous kernels.



Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1435_FC4

How reproducible:
Didn't try


Additional info:

/var/log/messages contains a whole bunch of lines like these:

    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BIF] (Node dee678c0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.AC__._PSR] (Node dee67aa0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BST] (Node dee678a0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BST] (Node dee678a0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BST] (Node dee678a0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BST] (Node dee678a0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BST] (Node dee678a0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BST] (Node dee678a0), AE_OWNE R_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0._BIF] (Node dee678c0), AE_OWNE 

Will attach 'lspci -vv' and dmesg output at boot time.

Comment 1 Øyvind Stegard 2005-08-26 01:20:12 UTC
Created attachment 118134 [details]
dmesg at boot time

Comment 2 Øyvind Stegard 2005-08-26 01:21:49 UTC
Created attachment 118135 [details]
lspci -vv

Comment 4 Dave Jones 2005-08-26 23:50:21 UTC
Can you try the latest errata kernel from updates-testing please ? That has an
ACPI update which could fix this.

Comment 5 Øyvind Stegard 2005-08-27 19:24:45 UTC
kernel-2.6.12-1.1435_FC4 seems to be the latest in updates-testing, at the
moment, which is the one showing the problem. Did you mean rawhide/development
(which currently seems to be kernel-2.6.12-1.1517_FC5) ? 

Perhaps interesting to note are these messages from kernel log, which I just got:
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00

Battery status monitoring still works, though. But I don't know for how long.
There is nothing suspicious in /var/log/acpid. The problem is not easy to
reproduce, and I don't know what causes it, but I'll report back on this bug
with newer versions from updates-testing, when they're released.

Comment 6 Øyvind Stegard 2005-08-27 19:30:22 UTC
Hmm, can't remember changing the bug status (?), anyway, I set it back to NEEDINFO.

Comment 7 Øyvind Stegard 2005-08-28 15:26:45 UTC
Getting more of these, but batt-stat is still working:
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:05.0 into 4x mode
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max),
AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.BAT0.Z001] (Node
dee66840), AE_OWNER_ID_LIMIT
    ACPI-0509: *** Error: Method execution failed [\_SB_.PCI0.ISA_.EC__._Q08]
(Node dee68c40), AE_OWNER_ID_LIMIT


Comment 8 Øyvind Stegard 2005-08-28 21:57:25 UTC
If I could, I'd change the bug title to "ACPI battery status stops working after
a while". It seems that if I just leave my laptop on long enough, it will
eventually break. This has happened again, after lots of the above ACPI error
messages in the log, including those initially reported, now last in the kernel
log. Once I start getting "ACPI-0145: *** Error: Invalid owner_id: 00", I can be
pretty sure it will stop working, in a few hours. The good news is I'll probably
be able to tell, with a fair amount of certainty, if the bug has gone away in an
updated kernel release.

Comment 9 Warren Togami 2005-08-29 22:52:25 UTC
My IBM Thinkpad T41 is now affected.  My previous kernel was
kernel-2.6.12-1.1398_FC4 which was working fine, but kernel-2.6.12-1.1447_FC4 is
now broken in this way.

Comment 10 Warren Togami 2005-08-30 02:25:45 UTC
Hmm something related to this is further hosed.  Maybe 6 hours after the battery
indicator stopped working, the laptop deadlocked.  kernel-2.6.12-1.1398_FC4 had
previously been fine for weeks of uptime.

Comment 11 Øyvind Stegard 2005-08-30 08:24:15 UTC
I'm still getting:

    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00

with kernel-2.6.12-1.1447_FC4. I bet the battery status will kill itself in a
matter of hours (though how many, I surely cannot say).

(In reply to comment #10)
> Hmm something related to this is further hosed.  Maybe 6 hours after the battery
> indicator stopped working, the laptop deadlocked.  kernel-2.6.12-1.1398_FC4 had
> previously been fine for weeks of uptime.
I haven't experienced lockups after batt-stat is dead. But it won't surprise me
if it happens, because by that stage my syslog is littered with ACPI ERROR messages.

Comment 12 Alexey Starikovskiy 2005-08-30 13:15:06 UTC
Created attachment 118249 [details]
Cleanup for acquire/release of owner_id

Comment 13 Warren Togami 2005-08-31 10:31:34 UTC
I've been running a custom built 2.6.13 vanilla for the past day and it has been
perfect here.  I hope we have a kernel update again sometime soon...

Comment 14 Jean-Francois Saucier 2005-08-31 12:47:54 UTC
Same problem here with kernel-2.6.12-1.1447_FC4 :

Aug 31 08:37:24 portable kernel:     ACPI-0145: *** Error: Invalid owner_id: 00
Aug 31 08:38:36 portable last message repeated 3 times
Aug 31 08:40:24 portable last message repeated 4 times
Aug 31 08:40:24 portable kernel:     ACPI-0145: *** Error: Invalid owner_id: 00
Aug 31 08:41:35 portable su(pam_unix)[4001]: session opened for user root by
(uid=500)
Aug 31 08:41:37 portable kernel:     ACPI-0145: *** Error: Invalid owner_id: 00
Aug 31 08:41:37 portable kernel:     ACPI-0145: *** Error: Invalid owner_id: 00
Aug 31 08:42:17 portable su(pam_unix)[4001]: session closed for user root
Aug 31 08:42:29 portable su(pam_unix)[4054]: session opened for user root by
(uid=500)
Aug 31 08:42:31 portable kernel:     ACPI-0145: *** Error: Invalid owner_id: 00
Aug 31 08:42:31 portable kernel:     ACPI-0145: *** Error: Invalid owner_id: 00
Aug 31 08:42:35 portable su(pam_unix)[4054]: session closed for user root
Aug 31 08:43:25 portable kernel:     ACPI-0105: *** Error: Could not allocate
new owner_id (32 max), AE_OWNER_ID_LIMIT
Aug 31 08:43:25 portable kernel:     ACPI-0509: *** Error: Method execution
failed [\_SB_.C044.C057.C0E7.C12B] (Node c14df6e0), AE_OWNER_ID_LIMIT
Aug 31 08:43:25 portable kernel:     ACPI-0509: *** Error: Method execution
failed [\_SB_.C12B] (Node c14dc580), AE_OWNER_ID_LIMIT
Aug 31 08:43:25 portable kernel:     ACPI-0509: *** Error: Method execution
failed [\_SB_.C137._BIF] (Node c14dc4a0), AE_OWNER_ID_LIMIT

Comment 15 Orion Poplawski 2005-08-31 17:23:02 UTC
Just a "me too".  See the following on a new ThinkPad X32:

Aug 30 19:54:36 makani kernel:     ACPI-0145: *** Error: Invalid owner_id: 00

with 2.6.12-1.1447_FC4

Comment 16 Øyvind Stegard 2005-08-31 20:03:56 UTC
I'm gonna try Alexey Starikovskiy's cleanup patch on 2.6.12-1.1447_FC4 (I use a
custom build of this kernel, anyway..). Will report back.

Comment 17 Øyvind Stegard 2005-08-31 22:54:47 UTC
(In reply to comment #16)
> I'm gonna try Alexey Starikovskiy's cleanup patch on 2.6.12-1.1447_FC4 (I use a
> custom build of this kernel, anyway..). Will report back.
2.6.12-1.1447_FC4 + owner_id-3.patch from Alexey Starikovskiy is so far looking
good. No ACPI error messages in syslog. But I might be drawing this conclusion
to soon, since I haven't had enough uptime to be sure, yet. Will re-confirm,
once it's been running a little longer.

Comment 18 Darren Fulton 2005-09-01 00:04:21 UTC
Me too.  Thinkpad T43.  Started after kernel update to: 2.6.12-1.1447_FC4 #1 Fri
Aug 26 20:29:51 EDT 2005 i686 i686 i386 GNU/Linux

Previous kernel did not have this problem.

KLaptop shows "Plugged in - no battery"


[root@lt1 ~]# dmesg
Non-volatile memory driver v1.2
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max),
AE_OWNER_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max),
AE_OWNER_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max),
AE_OWNER_ID_LIMIT
    ACPI-0105: *** Error: Could not allocate new owner_id (32 max),
AE_OWNER_ID_LIMIT


Comment 19 Øyvind Stegard 2005-09-01 07:35:39 UTC
(In reply to comment #17)
> 2.6.12-1.1447_FC4 + owner_id-3.patch from Alexey Starikovskiy is so far looking
> good. No ACPI error messages in syslog. But I might be drawing this conclusion
> to soon, since I haven't had enough uptime to be sure, yet. Will re-confirm,
> once it's been running a little longer.
Still good, the patch fixes the problem. I'm guessing it (or something similar
to it) will be included in the next Fedora kernel release.

2.6.12-1.1447_FC4 + owner_id-3.patch is confirmed working.


Comment 20 Richard Kennedy 2005-09-02 09:36:34 UTC
I'm also seeing this on my JVC minnote laptop 7230.

But additionally the ACPI hotkey HOTK events are not been seen by acpid. The
hotkeys worked in 1398. Do you think the owner_id-3.patch will fix this too?  

Comment 21 Øyvind Stegard 2005-09-02 09:44:41 UTC
I cannot say for sure, but at least it gets rid of all the error messages.
Battery status has worked fine ever since I applied it. This bodes well for ACPI
HOTK too, I would think (though I don't use it, myself).

Comment 22 Marcel Nijenhof 2005-09-03 09:19:35 UTC
After upgrading to the kernel 2.6.12-1.1398_FC4 i have the same messages.
After some time the systems hangs completly!!!

I have an ASUS L3800c

Comment 23 Yan-Fa Li 2005-09-03 17:37:40 UTC
I have a similar problem since upgrading to FC4 and 1447.  It's an older
Thinkpad T30, and believe it or not it's triggered when I push the Light LED
button, and shortly after that the laptop locks up, but I can keep the laptop
moving slowly by hitting the LED button on/off :)

Here's some of the output:

Sep  3 10:27:17 maat kernel:     ACPI-0105: *** Error: Could not allocate new
owner_id (32 max), AE_OWNER_ID_LIMIT
Sep  3 10:27:17 maat kernel:     ACPI-0563: *** Error: AE_OWNER_ID_LIMIT while
evaluating method [_L18] for GPE[ 0]

Comment 24 Yusuke Iwata 2005-09-04 02:21:10 UTC
I tried owner_id-3.patch. It looks good, no acpi error messages in
/var/log/messages. But I found another problem below. Only me?

(1) i unplug my ac_adapter.
--> acpid receives a event "battery BATA 00000080 00000001" only. No ac_adapter
event.
(2) i plug my ac_adapter.
--> acpid receives some events including an ac_adapter event.

(case1: 2.6.12-1.1447_FC4+owner_id-3.patch)
$ sudo /usr/sbin/acpid -d
[Sun Sep  4 10:17:01 2005] starting up
[Sun Sep  4 10:17:01 2005] DBG: parsing conf file /etc/acpi/events/power
[Sun Sep  4 10:17:01 2005] 1 rule loaded
[Sun Sep  4 10:17:02 2005] client connected from 3022[500:500]
[Sun Sep  4 10:17:02 2005] 1 client rule loaded
# unplugging my ac_adapter
[Sun Sep  4 10:17:10 2005] received event "battery BATA 00000080 00000001"
[Sun Sep  4 10:17:10 2005] DBG: rule from 3022[500:500] matched
[Sun Sep  4 10:17:10 2005] notifying client 3022[500:500]
[Sun Sep  4 10:17:10 2005] DBG: 1 total rule matched
[Sun Sep  4 10:17:10 2005] completed event "battery BATA 00000080 00000001"
# plugging my ac_adapter
[Sun Sep  4 10:17:41 2005] received event "processor CPU0 00000080 00000000"
[Sun Sep  4 10:17:41 2005] DBG: rule from 3022[500:500] matched
[Sun Sep  4 10:17:41 2005] notifying client 3022[500:500]
[Sun Sep  4 10:17:41 2005] DBG: 1 total rule matched
[Sun Sep  4 10:17:41 2005] completed event "processor CPU0 00000080 00000000"
[Sun Sep  4 10:17:41 2005] received event "processor CPU0 00000081 00000000"
[Sun Sep  4 10:17:41 2005] DBG: rule from 3022[500:500] matched
[Sun Sep  4 10:17:41 2005] notifying client 3022[500:500]
[Sun Sep  4 10:17:41 2005] DBG: 1 total rule matched
[Sun Sep  4 10:17:41 2005] completed event "processor CPU0 00000081 00000000"
[Sun Sep  4 10:17:41 2005] received event "battery BATA 00000080 00000001"
[Sun Sep  4 10:17:41 2005] DBG: rule from 3022[500:500] matched
[Sun Sep  4 10:17:41 2005] notifying client 3022[500:500]
[Sun Sep  4 10:17:41 2005] DBG: 1 total rule matched
[Sun Sep  4 10:17:41 2005] completed event "battery BATA 00000080 00000001"
[Sun Sep  4 10:17:41 2005] received event "ac_adapter AC 00000080 00000001"
[Sun Sep  4 10:17:41 2005] DBG: rule from 3022[500:500] matched
[Sun Sep  4 10:17:41 2005] notifying client 3022[500:500]
[Sun Sep  4 10:17:41 2005] DBG: 1 total rule matched
[Sun Sep  4 10:17:41 2005] completed event "ac_adapter AC 00000080 00000001"


(case2: 2.6.12-1.1398_FC4)
$ sudo /usr/sbin/acpid -d
[Sun Sep  4 10:28:08 2005] starting up
[Sun Sep  4 10:28:08 2005] DBG: parsing conf file /etc/acpi/events/power
[Sun Sep  4 10:28:08 2005] 1 rule loaded
[Sun Sep  4 10:28:09 2005] client connected from 3027[500:500]
[Sun Sep  4 10:28:09 2005] 1 client rule loaded
# unplugging my ac_adapter
[Sun Sep  4 10:28:26 2005] received event "processor CPU0 00000080 00000000"
[Sun Sep  4 10:28:26 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:26 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:26 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:26 2005] completed event "processor CPU0 00000080 00000000"
[Sun Sep  4 10:28:26 2005] received event "processor CPU0 00000081 00000000"
[Sun Sep  4 10:28:26 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:26 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:26 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:26 2005] completed event "processor CPU0 00000081 00000000"
[Sun Sep  4 10:28:26 2005] received event "battery BATA 00000080 00000001"
[Sun Sep  4 10:28:26 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:26 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:26 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:26 2005] completed event "battery BATA 00000080 00000001"
[Sun Sep  4 10:28:26 2005] received event "ac_adapter AC 00000080 00000000"
[Sun Sep  4 10:28:26 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:26 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:26 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:26 2005] completed event "ac_adapter AC 00000080 00000000"
[Sun Sep  4 10:28:27 2005] received event "battery BATA 00000080 00000001"
[Sun Sep  4 10:28:27 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:27 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:27 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:27 2005] completed event "battery BATA 00000080 00000001"
# plugging my ac_adapter
[Sun Sep  4 10:28:40 2005] received event "processor CPU0 00000080 00000000"
[Sun Sep  4 10:28:40 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:40 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:40 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:40 2005] completed event "processor CPU0 00000080 00000000"
[Sun Sep  4 10:28:40 2005] received event "processor CPU0 00000081 00000000"
[Sun Sep  4 10:28:40 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:40 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:40 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:40 2005] completed event "processor CPU0 00000081 00000000"
[Sun Sep  4 10:28:40 2005] received event "battery BATA 00000080 00000001"
[Sun Sep  4 10:28:40 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:40 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:40 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:40 2005] completed event "battery BATA 00000080 00000001"
[Sun Sep  4 10:28:40 2005] received event "ac_adapter AC 00000080 00000001"
[Sun Sep  4 10:28:40 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:40 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:40 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:40 2005] completed event "ac_adapter AC 00000080 00000001"
[Sun Sep  4 10:28:42 2005] received event "battery BATA 00000080 00000001"
[Sun Sep  4 10:28:42 2005] DBG: rule from 3027[500:500] matched
[Sun Sep  4 10:28:42 2005] notifying client 3027[500:500]
[Sun Sep  4 10:28:42 2005] DBG: 1 total rule matched
[Sun Sep  4 10:28:42 2005] completed event "battery BATA 00000080 00000001"

Comment 25 Øyvind Stegard 2005-09-04 09:16:34 UTC
(In reply to comment #24)
> I tried owner_id-3.patch. It looks good, no acpi error messages in
> /var/log/messages. But I found another problem below. Only me?
> 
> (1) i unplug my ac_adapter.
> --> acpid receives a event "battery BATA 00000080 00000001" only. No ac_adapter
> event.
> (2) i plug my ac_adapter.
> --> acpid receives some events including an ac_adapter event.
I've had problems with AC status change on my laptop since the first time I
installed Linux on it. acpid clients (like the Gnome batt-stat applet) don't
detect state changes because no event is received on AC disconnect. It's a
Compaq, and after some investigation into the problem, I found out it is most
likely the ACPI hardware (quirky ACPI implementation). However, it did work in
pre-installed Windows XP, but that was because of special Compaq driver _crap_,
I guess. I've given up on the problem (like I've given up getting ACPI suspend
to work =).

Comment 26 Tadej Janež 2005-09-04 13:04:24 UTC
Same thing here on a Compaq Evo N800v laptop. ACPI works fine under
kernel-2.6.12-1.1398_FC4, the problems started appearing with
kernel-2.6.12-1.1447_FC4.

Comment 27 Nigel Metheringham 2005-09-04 14:29:48 UTC
Me too (as comment #26) running on a Compaq Evo N800w.

Comment 28 Yan-Fa Li 2005-09-04 18:31:49 UTC
Patch from owner_id patch from Alexey @ Intel seems to have fixed the basic
problem on my T30.  Though there is a problem with the default kernel install
path it generates with modutils  because it uses an @ symbol and requires me to
softlink lib/modules otherwise it complains while booting.

Comment 29 Yan-Fa Li 2005-09-04 18:32:33 UTC
Owner_id patch from Alexey @ Intel seems to have fixed the basic problem on my
T30.  Though there is a problem with the default kernel install path it
generates with modutils  because it uses an @ symbol and requires me to softlink
lib/modules otherwise it complains while booting.

Comment 30 Karsten Wade 2005-09-06 08:25:39 UTC
I'm also getting this problem, Thinkpad T42 with an FC3 kernel:

kernel-2.6.12-1.1376_FC3

Similar set of symptoms:

* After a while of uptime, the battery applet stops responding (in Gkrellm)
* /var/log/messages starts to have acpi errors (see below)
* Twice so far the system has deadlocked; I hadn't connected the two events
before now


Here is the current batch of error output, every five seconds:

Sep  6 01:25:40 erato kernel:     ACPI-0105: *** Error: Could not allocate new
owner_id (32 max), AE_OWNER_ID_LIMIT
Sep  6 01:25:40 erato kernel:     ACPI-0105: *** Error: Could not allocate new
owner_id (32 max), AE_OWNER_ID_LIMIT
Sep  6 01:25:40 erato kernel:     ACPI-0509: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.BAT0._BIF] (Node dfe4c920), AE_OWNER_ID_LIMIT
Sep  6 01:25:40 erato kernel:     ACPI-0105: *** Error: Could not allocate new
owner_id (32 max), AE_OWNER_ID_LIMIT
Sep  6 01:25:40 erato kernel:     ACPI-0509: *** Error: Method execution failed
[\_SB_.PCI0.LPC_.EC__.BAT0._BST] (Node dfe4c900), AE_OWNER_ID_LIMIT


Comment 31 Warren Togami 2005-09-06 08:37:30 UTC
http://people.redhat.com/davej/kernels/Fedora/
Everyone please test the newer FC4 kernels from here.  I have been running
2.6.12-1.1451_FC4 for the past day and it has been good for me.

Comment 32 Tadej Janež 2005-09-06 09:49:09 UTC
A new kernel 2.6.12-1.1450_FC4 (perhaps very similar to the one Warren
suggested) is also available in updates-testing repository:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/ and
reading the changelog it looks promising:
* Sat Sep 03 2005 Dave Jones <davej@redhat.com>
- Various post 2.6.13 ACPI updates. (20050902)

I'll test it asap. 

Comment 33 Richard Kennedy 2005-09-06 13:53:28 UTC
I've tried davej/...1451_FC4.i686 on my JVC mininote

I'm still not seeing any acpi events, there's nothing appearing in the acpid log
after startup. Hotkeys don't work, as well as missing ac power events etc

But the invalid owner_id messages have gone away.


Comment 34 Øyvind Stegard 2005-09-06 14:02:21 UTC
2.6.12-1.1450_FC4 seems OK wrt. ACPI error messages and battery status.

Comment 35 Bryan Christ 2005-09-06 14:11:52 UTC
Just another incident reporting... this began happening on my Compaq nc6000
after I upgraded to 2.6.12-1.1447 and dbus-0.33-3 via yum.  After reading this
bugzilla, I doubt dbus has anything to do with the issue.  However, unlike some
of these other incident reports, I see the problem very quickly (less than an
hour, closer to 20 minutes).

Comment 36 Yan-Fa Li 2005-09-07 23:50:11 UTC
Began using 2.6.12-1.1450_FC4 yesterday.  No reoccurrence of the problem as yet.

Comment 37 Miloslav Trmač 2005-09-08 09:24:31 UTC
*** Bug 167013 has been marked as a duplicate of this bug. ***

Comment 38 Yusuke Iwata 2005-09-10 13:43:32 UTC
I tried davej/...1451_FC4.i686 on my panasonic cf-w4.
The invalid owner_id messages had gone away, but my another problem #24 was NOT.

So, I tried davej/....1454_FC4.i686 with "CONFIG_ACPI_DEBUG=y"(rebuilded).
The error messages below was logged in /var/log/messages, when I had
disconnected(connected) my ac_adapter.

osl-0913 [42] os_wait_semaphore     : Failed to acquire semaphore[c1476d80|1|0],
AE_TIME
osl-0913 [52] os_wait_semaphore     : Failed to acquire semaphore[c1472280|1|0],
AE_TIME
osl-0913 [65] os_wait_semaphore     : Failed to acquire semaphore[c1476d80|1|0],
AE_TIME
osl-0913 [40] os_wait_semaphore     : Failed to acquire semaphore[c1476d80|1|0],
AE_TIME
osl-0913 [40] os_wait_semaphore     : Failed to acquire semaphore[c1476d80|1|0],
AE_TIME
...(same messages was logged many times.)

Comment 39 Johannes Reykdal 2005-09-10 14:00:52 UTC
Same symptoms on hp nx7010 running 2.6.12-1.1447_FC4.

Will try 1454 now.

Comment 40 Walter Neumann 2005-09-10 17:19:02 UTC
Same problem on an OEM laptop. 2.6.12-1.1454_FC4 seems to fix it, but 
it does not yet fix the missing /proc/acpi/button 

Comment 41 Richard Kennedy 2005-09-11 15:08:19 UTC
With davej's kernel-2.6.12-1.1454_FC4 on JVC mininote 
- the batstat app is unable to access the stats consistently, and after about 15
minutes gets stuck reading 0%.
- "cat /proc/acpi/batery/BAT0/state" is inconsistent, sometimes reading 0, and
very slow to complete, 1+seconds.
- acpid still not getting any events -- lid, hotkey etc


Comment 42 Karsten Wade 2005-09-12 20:39:42 UTC
I installed the kernel-2.6.12-1.1376_FC3 package from davej's people.r.c page.  

So far, so good.  28 hours of uptime, no complaints from ACPI to syslog, battery
status applet is working fine (in gkrellm), and no deadlock.


Note You need to log in before you can comment on or make changes to this bug.