Bug 167013 - "Could not allocate new owner_id" when reading battery status
"Could not allocate new owner_id" when reading battery status
Status: CLOSED DUPLICATE of bug 166816
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On: 166816
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-29 11:56 EDT by Miloslav Trmač
Modified: 2015-01-04 17:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 05:24:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (33.63 KB, text/plain)
2005-08-29 11:56 EDT, Miloslav Trmač
no flags Details
DSDT disassembly, FWIW (165.80 KB, text/plain)
2005-08-29 11:58 EDT, Miloslav Trmač
no flags Details

  None (edit)
Description Miloslav Trmač 2005-08-29 11:56:12 EDT
# cat /proc/acpi/battery/BAT0/info
present:                 yes
ERROR: Unable to read battery information
# cat /proc/acpi/battery/BAT0/state
present:                 yes
ERROR: Unable to read battery status

dmesg (attached) contains ACPI complaints about owner_id

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4.i686.
Worked fine with kernel-2.6.12-1.1398_FC4.i686

Hardware:
Fujitsu-Siemens Amilo Pro V2000
Comment 1 Miloslav Trmač 2005-08-29 11:56:12 EDT
Created attachment 118211 [details]
dmesg
Comment 2 Miloslav Trmač 2005-08-29 11:58:28 EDT
Created attachment 118212 [details]
DSDT disassembly, FWIW
Comment 3 Colin Charles 2005-09-01 07:45:56 EDT
I don't know if this is related, but on my Thinkpad R51, and 2.6.12-1.1447_FC4
kernel, I see similar messages in the dmesg attachment that mitr is encountering:
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00
    ACPI-0145: *** Error: Invalid owner_id: 00

It appears to grow, and wasn't present in the last updates-released kernel for FC-4.
Comment 4 Colin Charles 2005-09-01 20:44:02 EDT
Ok, scracth comment #3. I get exactly a similar response as mitr is getting only
_after_ I close the LID, and the machine isn't set to sleep (but the screen
blanks). And consequently, battery status can't be read, and the GNOME display
shows "System is running on battery power. Battery status unknown" even when
plugged in to AC power. 

This was not an issue in 1398, but only in the new 1447.
Comment 5 Alexey Starikovskiy 2005-09-02 05:03:53 EDT
Could you please try patch in #166816? 
Comment 6 Miloslav Trmač 2005-09-08 05:24:07 EDT
Thanks, the patch fixes it.

*** This bug has been marked as a duplicate of 166816 ***
Comment 7 quang 2005-10-18 00:41:26 EDT
"Could you please try patch in #166816? "

could someone tell me how to do this patch?  Thank you.

Note You need to log in before you can comment on or make changes to this bug.