Bug 166822 - Solaris 10 client unable to use NFSv4 for RHEL4 exports
Solaris 10 client unable to use NFSv4 for RHEL4 exports
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
http://www.unixgroups.com/printthread...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 00:21 EDT by David Kelertas
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 10:03:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ethereal Bzip2 log file during NFSv4 session failed (15.44 KB, application/octet-stream)
2005-09-19 02:21 EDT, David Kelertas
no flags Details
Tethereal -w bzip2 outtput on RHEL4 server using NFSv4 (12.99 KB, application/octet-stream)
2005-09-19 21:32 EDT, David Kelertas
no flags Details

  None (edit)
Description David Kelertas 2005-08-26 00:21:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Solaris 10 client unable to mount RHEL4 NFS exported mounts
Error on Solaris client is:



Version-Release number of selected component (if applicable):
kernel-2.6.9-5.ELsmp (RHEL4 Nahant)

How reproducible:
Always

Steps to Reproduce:
1. Mount any exported NFS directory on a RHEL4 server on any Solaris 10 client
2.
3.
  

Actual Results:  
Output from Solaris 10 client command line:
"Permission Denied"

Output from /var/adm/messages on Solaris 10 client:
Aug 26 11:59:49 solaris10.preston.net nfs: [ID 435675 kern.warning] WARNING: NFS server initial call to rhel4box failed: Not owner
Aug 26 11:59:49 solaris10.preston.net automountd[2288]: [ID 834250 daemon.error] Mount of rhel4box:/home/staff/taamtest1 on /staff/taamtest1: Not owner

Expected Results:  Successful mount without error.

Additional info:

On modifying Solaris client to use NFSv3 by modifying "NFS_CLIENT_VERSMAX=3" in /etc/default/nfs on the Solaris 10 client, 
the mount is successful.

Will also logg a bug with SUN support. Please try and resolve the
problem instead of pointing fingers at each other.
Comment 1 Steve Dickson 2005-08-26 07:35:53 EDT
"Permission Denied" generally means there is an export
problem on the server. What do the exports on the server
look like? Also an bzip2 tethereal network trace would
be good as well.
Comment 2 David Kelertas 2005-09-19 02:21:58 EDT
Created attachment 118957 [details]
Ethereal Bzip2 log file during NFSv4 session failed
Comment 3 David Kelertas 2005-09-19 02:24:37 EDT
The following /etc/exports is on the RHEL4 server which hosts
the export (/home/staff/james).

/home *(rw,no_root_squash)
/tmp *(rw,no_root_squash)


The "permission denied" error was generated on the Solaris 10 client.

Comment 4 Steve Dickson 2005-09-19 09:36:48 EDT
Try the following exports:

/ *(ro,sync,fsid=0)
/home *(rw,sync,nohide,no_root_squash)

if /home is a different filesystem then try

/ *(ro,sync,fsid=0)
/home *(rw,sync,nohide,no_root_squash,fsid=1)

Also having a binary ethereal trace would be
better than an ascii one, since it allows one
to dig down into the details of the protocols.

To generate a binary trace use the -w flag.
i.e. tethereal -w /tmp/trace.pcap host server



Comment 5 David Kelertas 2005-09-19 21:31:18 EDT
As the original RHEL4 server (caracal) is in production
I have used my own desktop (steven) running RHEL4 as an 
NFSv4 server. It has the following exports as recommended:

File: /etc/exports on steven.preston.net
/ *(ro,sync,fsid=0)
/win *(rw,sync,nohide,no_root_squash,fsid=1)

Mounting steven:/win /tmp/mnt on the Solaris 10 client (boxer)
was successful without any error.   The tethereal binary output 
(nfsv4.log.bz2) during the above attempt is attached. Please
note that the IP address of boxer is 202.14.10.28.

Comment 6 David Kelertas 2005-09-19 21:32:52 EDT
Created attachment 119007 [details]
Tethereal -w  bzip2 outtput on RHEL4 server using NFSv4
Comment 7 Steve Dickson 2005-09-21 09:04:21 EDT
Good... I'm glad hear things are working... 
So can I close this bug?
Comment 8 David Kelertas 2005-09-21 20:46:27 EDT
Can you please explain why "fsid" option is required
to get NFSv4 working, is this a bug, will this break
all previous exports that used to work in RHEL3 ?

Comment 9 David Lehman 2005-09-29 20:08:09 EDT
It's important to note this is not specific to Solaris clients. RHEL4 and FC3
clients behave the same way.

Setting to NEEDINFO_ENG until comment 8 is answered.
Comment 13 Scott Hankin 2006-05-19 11:09:48 EDT
We've taken to creating /etc/sysconfig/nfs with the line

RPCNFSDARGS="-N 4"

to handle this issue.  Many of our machines only export /.
Comment 14 Jeff Layton 2007-07-18 10:03:19 EDT
David,
  fsid=0 denotes the root of the NFSv4 namespace. NFSv4 is different from v2/3
in that the exported namespace can be different from how the actual filesystem
looks on the server (note that some of this is still work in progress upstream).

Given that this doesn't seem to have been a bug, I'll close it as such.


Note You need to log in before you can comment on or make changes to this bug.