Bug 166841 - Share the same input method among all applications
Share the same input method among all applications
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks: 171491 SCIM
  Show dependency treegraph
 
Reported: 2005-08-26 08:04 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 07:50:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2005-08-26 08:04:17 EDT
SCIM Setup -> Frontend -> Global Setup ->
              Share the same input method among all applications

scim's default settings for a new user should set this enabled by default.
Comment 1 Jens Petersen 2005-09-13 02:55:40 EDT
However this has some consequences - like IM is activated for new apps
at startup i think - perhaps there is a config option to change that though?
Comment 2 Warren Togami 2005-09-13 02:57:19 EDT
> IM is activated for new apps at startup

Is this always a bad thing?
Comment 3 Jens Petersen 2005-09-13 03:25:58 EDT
Often at least - but maybe something can be done about it.
Certainly for many apps it is quite annoying.
Comment 4 Warren Togami 2005-09-13 04:15:27 EDT
What is this behavior by default in Windows?
Comment 5 Jens Petersen 2006-02-03 09:29:08 EST
In Windows I believe the default is native language input.
But people have told me they want ascii input by default.
Comment 6 Warren Togami 2006-02-06 00:22:30 EST
*** Bug 170481 has been marked as a duplicate of this bug. ***
Comment 7 Akira TAGOH 2006-02-06 00:24:51 EST
Comment #5:
depends. ascii input is still default for notepad say. IME may be controlled
under the Office suite.
Comment 8 Warren Togami 2006-02-06 00:31:55 EST
Hmm, it does make sense that the application decides whether it should be
enabled or disabled by default.  If you are using notepad for example, you are
more likely to be editing an ASCII file than in a word processor application.

I plan on doing more testing of SCIM's default behavior and to compare it to
other operating systems.
Comment 9 Akira TAGOH 2006-02-06 01:44:36 EST
I missed Comment #1 and have an idea for that.
Actually scim-anthy supports such things and you can always enable IM at the
startup time with it - of course could be with ascii mode but anyway.
steps are
1. turn on "Share the same input method among all applications" check box in
FrontEnd -> Global Setup
2. change Input mode to Latin to be ascii mode for default or to Hiragana in
Common tab in IMEngine -> Anthy.
3. it may be good for Windows user to change the keybinding theme to MS-IME-like
at Key bindings theme in Key bindings tab in IMEngine -> Anthy.

What benefit there are are you can (de)activate IME with what you could do on
Windows. I mean Kanji key just works for that.

We need much more feedbacks if we would change the default keybindings. the
survery result wasn't sufficient to do it. it would rather keeps current one.

FYI
Comment 10 Jens Petersen 2006-02-07 05:53:27 EST
None of the other IMEs currently seem to support setting English as
the default input mode currently, though I suppose it would not be so
hard to add such a feature to each one.  Also I agree ideally the default
mode should depend on the application, though currently there is no way for
a gtk immodule to give that information.  scim-hangul and scim-m17n don't
have an English input mode yet either.
Comment 11 Warren Togami 2006-02-08 02:40:16 EST
In response to the comment "more feedbacks if we would change the default
keybindings. the survery result wasn't sufficient to do it".

This is exactly why I opposed the idea of this survey.  The kind of survey we
conducted was problematic because it is self-selecting.  We had only a tiny
population of users taking the survey, and the results from that group are no
representative of our target market.

It is plainly obvious that changing the default keybinding for activation is
critical for the Japanese user.  I would assert that any thoughts to the
contrary are insular engineer thinking.  Engineers are not exposed to regular
users, and the software that regular users know.  If we want to have any chance
of winning those users, we must make our software behave exactly as they expect
without the need for documentation or training.

About the other topics in this bug, I wish to think more before responding.
Comment 12 Jens Petersen 2006-02-13 23:27:25 EST
The main issues I see:

1. Do we need the main scim on/off toggle (Ctrl-Space)?  (Currently, yes, since
   some IMEs don't have an ascii mode yet.)

2. For global IC mode, should scim default to being on (current) or off by default
   (probably off for now, until all our IMEs have ascii mode).

3. Global IC mode needs exposure out in the wild, since the code seems to be
   less tested (read "more buggy UI-wise") than Local IC mode.
Comment 13 Jens Petersen 2006-02-24 09:01:17 EST
Turning on Shared Input Mode by default in scim-1.4.4-6.
Comment 14 Jens Petersen 2006-03-01 07:50:48 EST
Default reverted in 1.4.4-8 since Shared Mode is too intrusive
(actually it was not enabled in -6 yet due to an unapplied patch).

Until all IMEs have their own input modes, defaulting to Shared Mode seems
impractical.  (Japanese users can use Shared Mode comfortably with
scim-anthy's default mode set to ASCII ("_A").)

My thinking now is that the current default actually provides
a better UI for users in general.

Note You need to log in before you can comment on or make changes to this bug.