Bug 1668828 - installation fails with PV annotations missing
Summary: installation fails with PV annotations missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.11.z
Assignee: Vadim Rutkovsky
QA Contact: Gaoyun Pei
URL:
Whiteboard:
: 1669174 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-23 16:30 UTC by Aleksandar Kostadinov
Modified: 2019-02-20 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-20 14:11:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0326 None None None 2019-02-20 14:11:07 UTC

Description Aleksandar Kostadinov 2019-01-23 16:30:19 UTC
Description of problem:
Installation all-in-one on OpenStack with cloudprovider support and NFS registry fails.

Version-Release number of the following components:
openshift-ansible: 3.11.73-1.git.0.89d3763.el7
ansible version: 2.6.12-1.el7ae

How reproducible:
always

Steps to Reproduce:
1. trigger installation

Actual results:

> TASK [openshift_persistent_volumes : Deploy PersistentVolume definitions] ******
> Wednesday 23 January 2019  23:08:29 +0800 (0:00:00.099)       0:09:22.458 ***** 
> fatal: [vm-10-0-76-205.hosted.upshift.rdu2.redhat.com]: FAILED! => {"changed": false, "msg": "AnsibleUndefinedVariable: 'dict object' has no attribute 'annotations'"}
> 	to retry, use: --limit @/home/slave4/workspace/Launch Environment Flexy/private-openshift-ansible/playbooks/deploy_cluster.retry

Expected results:
SUCCESS

Comment 3 Scott Dodson 2019-01-24 15:46:27 UTC
*** Bug 1669174 has been marked as a duplicate of this bug. ***

Comment 6 Gaoyun Pei 2019-01-29 03:18:04 UTC
Verify this bug with openshift-ansible-3.11.75-1.git.0.95e8e2a.el7.noarch.rpm

Install all-in-one 3.11 env on OpenStack with cloudprovider support and NFS backend docker-registry:


TASK [openshift_persistent_volumes : Deploy PersistentVolume definitions] ******
Tuesday 29 January 2019  10:58:46 +0800 (0:00:00.102)       0:09:39.225 ******* 
ok: [host-8-246-135.host.centralci.eng.rdu2.redhat.com] => {"changed": false, "checksum": "39ce8561d5e299d4aa61079e15d16703953c7704", "dest": "/tmp/openshift-ansible-HGkmOTs/persistent-volumes.yml", "gid": 0, "group": "root", "md5sum": "e47c362582f857dda2253c3f8078dd6c", "mode": "0644", "owner": "root", "secontext": "unconfined_u:object_r:admin_home_t:s0", "size": 381, "src": "/root/.ansible/tmp/ansible-tmp-1548730726.86-52894864996169/source", "state": "file", "uid": 0}

TASK [openshift_persistent_volumes : Create PersistentVolumes] *****************
Tuesday 29 January 2019  10:58:47 +0800 (0:00:00.510)       0:09:39.735 ******* 
changed: [host-8-246-135.host.centralci.eng.rdu2.redhat.com] => {"changed": true, "cmd": ["oc", "create", "-f", "/tmp/openshift-ansible-HGkmOTs/persistent-volumes.yml", "--config=/tmp/openshift-ansible-HGkmOTs/admin.kubeconfig"], "delta": "0:00:00.199926", "end": "2019-01-28 21:59:02.681807", "failed_when_result": false, "rc": 0, "start": "2019-01-28 21:59:02.481881", "stderr": "", "stderr_lines": [], "stdout": "persistentvolume/regpv-volume created", "stdout_lines": ["persistentvolume/regpv-volume created"]}

Comment 8 errata-xmlrpc 2019-02-20 14:11:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0326


Note You need to log in before you can comment on or make changes to this bug.