Bug 1669174 - pv task fails with AnsibleUndefinedVariable
Summary: pv task fails with AnsibleUndefinedVariable
Keywords:
Status: CLOSED DUPLICATE of bug 1668828
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-24 14:21 UTC by Jason Montleon
Modified: 2019-01-24 15:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-24 15:46:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jason Montleon 2019-01-24 14:21:48 UTC
Description of problem:

Version-Release number of the following components:
openshift-ansible 3.11.73-1.git.0.89d3763.el7
ansible 2.6.12-1.el7ae

How reproducible:
Seems 100% so far, but only two tries.

Steps to Reproduce:
1. Install 3.11 

Actual results:
Install fails with:
    default: TASK [openshift_persistent_volumes : Deploy PersistentVolume definitions] ******
    default: fatal: [192.168.121.220.nip.io]: FAILED! => {"changed": false, "msg": "AnsibleUndefinedVariable: 'dict object' has no attribute 'annotations'"}

Expected results:
Install Succeeds

Additional info:
Up to openshift-ansible 3.11.72-1.git.0.7c8b4f0.el7 with ansible 2.6.12-1.el7ae worked.

Comment 2 Scott Dodson 2019-01-24 15:46:27 UTC

*** This bug has been marked as a duplicate of bug 1668828 ***


Note You need to log in before you can comment on or make changes to this bug.