Bug 166896 - build directory is broken link
build directory is broken link
Status: CLOSED DUPLICATE of bug 163406
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 19:54 EDT by Mike Benson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 19:56:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Benson 2005-08-26 19:54:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
I am unable to build modules for this kernel. the build directory in /lib/modules/2.6.12-1.1372_FC3 is a broken link:
lrwxrwxrwx  1 root root     49 Jul 17 04:49 build -> ../../../usr/src/kernels/2.6.12-1.1372_FC3-x86_64
There is also a broken link source - > build

Version-Release number of selected component (if applicable):
2.6.12-1.1372_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-2.6.12-1.1372_FC3.x86_64.rpm
2. Try to build any external kernel module, eg ndiswrapper, make will fail.

  

Actual Results:  external module (built, installed and running under 2.6.11-1.35.FC3) can not be built.

Expected Results:  extrenal module can be installed using make && make install

Additional info:
Comment 1 Dave Jones 2005-08-26 19:56:33 EDT

*** This bug has been marked as a duplicate of 163406 ***

Note You need to log in before you can comment on or make changes to this bug.