This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 166900 - jpilot complains that the user ID of the last synch is not the same
jpilot complains that the user ID of the last synch is not the same
Status: CLOSED DUPLICATE of bug 166897
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 20:04 EDT by Marcelo Roberto Jimenez
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 10:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix this issue. Apply against pre4. (849 bytes, patch)
2005-08-26 20:04 EDT, Marcelo Roberto Jimenez
no flags Details | Diff

  None (edit)
Description Marcelo Roberto Jimenez 2005-08-26 20:04:52 EDT
Description of problem:
When trying to sync the palm device through serial port, jpilot would complain
that the user ID of the last synch was not the same. What was happening in fact
was that pilot-link was giving a timeout receive error.

The error was caused by some uninitialized variables, more specificaly,
freeze_txid had garbage, and most of the time evaluated to true. That made the
error intermitent.

I will attach a patch that solves the issue. I have already sent a patch to
pilot-link-devel list. Notice that the following patch applies only to pre4,
which is the version I found in rawhide. The patch I sent to pilot-link-devel
applies to CVS.

Version-Release number of selected component (if applicable):
pilot-link-0.12.0-pre4 and all before

How reproducible:
Almost always.

Steps to Reproduce:
1. Press synch on the gui
2. Press synch button on the palm
3. voilá.
Comment 1 Marcelo Roberto Jimenez 2005-08-26 20:04:52 EDT
Created attachment 118177 [details]
Patch to fix this issue. Apply against pre4.
Comment 2 Ngo Than 2005-09-14 10:36:29 EDT

*** This bug has been marked as a duplicate of 166897 ***

Note You need to log in before you can comment on or make changes to this bug.