Bug 166980 - Review Request: kmymoney2: Personal finance
Review Request: kmymoney2: Personal finance
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Quentin Spencer
David Lawrence
http://kmymoney2.sourceforge.net/
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-08-29 08:27 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 15:16:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full gzip'd output of rpmbuild (19.38 KB, application/x-gzip)
2005-09-01 00:41 EDT, Jerry Amundson
no flags Details

  None (edit)
Description Rex Dieter 2005-08-29 08:27:41 EDT
Spec Name or Url: http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney-0.8-1.spec
SRPM Name or Url: http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney-0.8-1.src.rpm
Description: 
KMyMoney is striving to be a full-featured replacement for your
Windows-based finance software.  We are a full double-entry accounting
software package, for personal or small-business use.

Here's our cumulative feature list:
* Double-entry (Integer-based) accounting system
* Support checking accounts, savings accounts, credit cards, loans,
mortgages, cash, asset, and liability accounts
* Default category lists for several countries, and user-defined
categories available
* XML file format for saving data
* QIF file import/export for external data, including user-definable
QIF schema
* Allows arbitrary hierarchy of expense and income categories
* Translations available for French, German and Russian
* Ability to create scheduled transactions
* Transaction entry in a user-friendly checkbook type form or an editable
register
* Compact ledger layout, but also contains a 'ledger-lens' to show all
details of the 'current' selected transaction
* display of transactions per payer/payee
* Support of split transactions for multiple categories and accounts
* Powerful transaction search function
* User-friendly wizards to guide users through more complicated tasks,
such as setting up a loan
* Adjustable 'home-page' to show important information to the user
after start-up
Comment 2 Quentin Spencer 2005-08-30 11:16:27 EDT
This isn't a complete review, but rpmlint on the SRPM gave me:
E: kmymoney2 invalid-spec-name kmymoney2-0.8-1.spec

I think the spec file should not have the version in it.

I tried building the file and got the following error:
    File not found by glob:
/var/tmp/kmymoney2-0.8-1-root-qspencer/usr/share/applications/*/*.desktop


Looking at the spec file, it looks like you have some optional build parameters.
I'm not sure what the Fedora Extras policy is on things like this, but I think
it would be preferred to just build with all options and simplify the spec file
if possible.
Comment 3 Rex Dieter 2005-08-30 11:44:37 EDT
%changelog
* Tue Aug 30 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8-2
- simplify specfile
- fix build

Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney2-0.8-2.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney2-0.8-2.src.rpm
Comment 4 Quentin Spencer 2005-08-30 18:00:42 EDT
OK, the updated version now builds, installs, and uninstalls on my system with
no problems, and source matches upstream. No rpmlint problems with SRPM, there
are some minor ones with the the RPMs:

$ rpmlint kmymoney2-0.8-2.i386.rpm
W: kmymoney2 dangling-symlink /usr/share/doc/HTML/en/kmymoney2/common
/usr/share/doc/HTML/en/common
W: kmymoney2 symlink-should-be-relative /usr/share/doc/HTML/en/kmymoney2/common
/usr/share/doc/HTML/en/common

$ rpmlint kmymoney2-devel-0.8-2.i386.rpm
W: kmymoney2-devel no-provides kmymoney-devel
W: kmymoney2-devel no-documentation

I'm out of time right now. I'll look in more detail at the spec file later.
Comment 5 Jerry Amundson 2005-09-01 00:38:46 EDT
RPM build errors: 
    Installed (but unpackaged) file(s) found: 
   /usr/lib/kde3/kmm_ofximport.la 
   /usr/lib/kde3/kmm_ofximport.so 
   /usr/share/services/kmm_ofximport.desktop 
 
With these installed, --enable-ofxplugin actually works... 
 
[root@elm ~]# rpm -qa libofx\* openjade\* 
libofx-0.7.0-3 
openjade-1.3.2-16 
libofx-devel-0.7.0-3 
openjade-devel-1.3.2-16 
 
Comment 6 Jerry Amundson 2005-09-01 00:41:06 EDT
Created attachment 118330 [details]
full gzip'd output of rpmbuild
Comment 7 Rex Dieter 2005-09-01 07:47:16 EDT
I didn't see those missing files, but we didn't use
BuildRequires: libofx-devel
I would have expected configure to die if I gave --enable-ofxplugin and libofx
wasn't found.
Comment 8 Rex Dieter 2005-09-01 10:46:23 EDT
%changelog
* Thu Sep 01 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8-3
- BR: libofx-devel

Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney2-0.8-3.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney2-0.8-3.src.rpm
Comment 9 Dennis Gilmore 2005-09-10 11:10:45 EDT
build fails on x86_64   
checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. 
Please check your installation! 
For more details about this problem, look at the end of config.log. 
Make sure that you have compiled Qt with thread support! 
error: Bad exit status from /var/tmp/rpm-tmp.21811 (%build) 
 
 
RPM build errors: 
    Bad exit status from /var/tmp/rpm-tmp.21811 (%build) 
 
to fix  add to %build 
unset QTDIR || : ; . /etc/profile.d/qt.sh 
export QTLIB=${QTDIR}/lib QTINC=${QTDIR}/include 
 
for some reason  fc4 x86_64  doesnt  pick up the qt stuff properly  
 
 
I dont know if for extras the kde-redhat stuff shouldnt be removed from the 
spec file.   
 
on x86  build is ok.  going to build on sparc and ppc later today.  not that 
sparc has any effect on inclusion in extras  i just like it :).   
Comment 10 Aurelien Bompard 2005-09-26 05:51:09 EDT
Setting this bug as "under review". Feel free to change the assignment, I just
used the last commentor
Comment 11 Rex Dieter 2005-10-21 17:49:09 EDT
* Fri Oct 21 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8-4
- %%post,%%postun: gtk-update-icon-cache, update-desktop-database
- omit lib*.la
- x86_64: set QTDIR/QTLIB

Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney2-0.8-4.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney2-0.8-4.src.rpm
Comment 12 Rex Dieter 2005-11-07 10:58:03 EST
Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney2-0.8.1-1.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney2-0.8.1-1.src.rpm

%changelog
* Sat Nov 05 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8.1-1
- 0.8.1

* Fri Nov 04 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8-5
- drop useless macros
- use %%fedora,%%rhel to conditionalize ofxbanking support

Comment 13 Quentin Spencer 2005-11-09 10:53:05 EST
I have built the latest version with no problems, and everything installs and
uninstalls fine.

Output of rpmlint on kmymoney2:
W: kmymoney2 dangling-symlink /usr/share/doc/HTML/en/kmymoney2/common
/usr/share/doc/HTML/en/common
W: kmymoney2 symlink-should-be-relative /usr/share/doc/HTML/en/kmymoney2/common
/usr/share/doc/HTML/en/common

Output of rpmlint on kmymoney2-devel:
W: kmymoney2-devel no-provides kmymoney-devel
W: kmymoney2-devel no-documentation

I'm not sure why rpmlint thinks that the lack of providing kmymoney-devel is a
problem, I don't see it as a blocker.

There are a lot of macros in the spec file, as noted by a previous reviewer,
which seem to be for kde-redhat. I don't know if that's necessarily a problem,
but if any of them are not used in FE, I think some comments should be added to
explain what they do and why they are not used. For example, what does
_with_kbanking do, and why is it not enabled (or at least it appears not to be)?
The others are pretty clear, I think.

I would also suggest a more concise package description, though I wouldn't
consider that a blocker.
Comment 14 Rex Dieter 2005-11-09 11:01:26 EST
> There are a lot of macros in the spec file, as noted by a previous reviewer,
> which seem to be for kde-redhat

All of those were dropped since 0.8-5 (as noted in the changelog)

> For example, what does _with_kbanking do, and why is it not enabled (or at 
> least it appears not to be)?

Not enabled due to missing dependancies: kbanking-devel (and a newer acqbanking
rpm).  

> I would also suggest a more concise package description, 
> though I wouldn't consider that a blocker.

Agreed, I'll trim that and release an update in a bit.
Comment 15 Rex Dieter 2005-11-09 11:03:42 EST
Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney2-0.8.1-2.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney2-0.8.1-2.src.rpm

%changelog
* Wed Nov 09 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8.1-2
- qt-3.3.5 patch
- 'make check' workaround (kde bug #115863)
- trim %%description
Comment 16 Quentin Spencer 2005-11-09 15:28:37 EST
I looked at the rpmlint warnings again. I now see that the dangling symlink is
unavoidable since it apparently links to external kde stuff. However, the
non-relative symlink is still there. It appears you tried to change it in the
specfile but it didn't work quite right for me. Take a look at the change below
and see if that's what you need to make it go away.


--- kmymoney2-0.8.1-2.spec       2005-11-09 14:24:21.000000000 -0600
+++ kmymoney2.spec      2005-11-09 12:01:42.000000000 -0600
@@ -87,8 +87,8 @@
 for lang in *; do
   if [ -d $lang ]; then
     pushd $lang
-    for i in */*; do
-      [ -d $i -a -L $i/common ] && rm -f $i/common && ln -sf ../../common $i/common
+    for i in *; do
+      [ -d $i -a -L $i/common ] && rm -f $i/common && ln -sf ../common $i/common
     done
     popd
   fi
Comment 17 Rex Dieter 2005-11-10 09:12:16 EST
Thanks.  Ugh.. I just copy-n-pasted that code from one of the other packages I
maintain, so it looks like a few others are probably broken the same way.

Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/kmymoney2-0.8.1-3.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.stable/kmymoney2-0.8.1-3.src.rpm

%changelog
* Thu Nov 10 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.8.1-3
- fix relative symlinks
Comment 18 Quentin Spencer 2005-11-10 12:44:03 EST
Well, I think this package is ready, but I'm not the assignee. If someone knows
how to reassign this to me, I'll approve it.
Comment 19 Dennis Gilmore 2005-11-10 13:14:50 EST
Sorry that i havent had the time to give this a full review. but I really 
appreciate that someone has had that time. 
Comment 20 Quentin Spencer 2005-11-10 15:16:33 EST
-License is OK.
-Spec file appears to meet all the necessary criteria.
-Builds and installs on i386 (note that other testers reported build problems on
x86_64 with earlier versions, but it is unknown whether the problems persist
with the newest update).

rpmlint output on main package
W: kmymoney2 dangling-relative-symlink /usr/share/doc/HTML/en/kmymoney2/common
../common

This is OK, it refers to an external KDE directory that will be present on the
system.

rpmlint output on devel package:
W: kmymoney2-devel no-provides kmymoney-devel
W: kmymoney2-devel no-documentation

I think the first warning can be ignored. I can't figure out the reason for the
second one, as there are other devel packages that don't include a %doc section
in the files list and don't produce this error, so for now, I say ignore it.

Approved.

Note You need to log in before you can comment on or make changes to this bug.