Bug 166987 - traceback about not finding gnome.applet after upgrading to version 0.4.5
traceback about not finding gnome.applet after upgrading to version 0.4.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: revelation (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
: 167109 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 09:51 EDT by Tadej Janež
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 11:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tadej Janež 2005-08-29 09:51:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
[tadej@tlinux-stable ~]$ revelation
Traceback (most recent call last):
  File "/usr/bin/revelation", line 30, in ?
    from revelation import gnomemisc, config, data, datahandler, dialog, entry, io, ui, util
  File "/var/tmp/revelation-0.4.5-buildroot-mockbuild/usr/lib/python2.4/site-packages/revelation/__init__.py", line 29, in ?
ImportError: could not import gnome.applet
[tadej@tlinux-stable ~]$

Note: I don't know where the reference to /var/tmp/revelation-0.4.5-buildroot-mockbuild/... comes from because I didn't rebuild the package myself (even if I did, it shouldn't reference something in RPM_BUILD_ROOT).

I think gnome.applet is/was deprecated and it should be using gnomeapplet instead.

Version-Release number of selected component (if applicable):
revelation-0.4.5-1.fc4

How reproducible:
Always

Steps to Reproduce:
1. start revelation
2.
3.
  

Additional info:
Comment 1 Thorsten Leemhuis 2005-08-29 10:06:35 EDT
thx for the report; Installing gnome-python2-applet fixes it; I'll prepare an
update where this will be fixed.

Comment 2 Thorsten Leemhuis 2005-08-29 11:39:17 EDT
Updated package build; Currently waits for signing and should go online soon. 
Comment 3 Michael Schwendt 2005-08-29 11:50:55 EDT
> /var/tmp/revelation-0.4.5-buildroot-mockbuild/

comes from an incorrectly precompiled Python file.
Comment 4 Thorsten Leemhuis 2005-08-30 12:51:07 EDT
*** Bug 167109 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.