Bug 167049 - aic7xxx is confused when 4 GB memory (remapped) is available
aic7xxx is confused when 4 GB memory (remapped) is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 15:54 EDT by Göran Uddeborg
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 19:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log from /var/log/messages (77.58 KB, text/plain)
2005-08-29 15:54 EDT, Göran Uddeborg
no flags Details
Output of "lsmod" (2.49 KB, text/plain)
2005-08-29 15:55 EDT, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2005-08-29 15:54:01 EDT
Description of problem:
During boot, the aic7xxx module is confused, and believes there are a large
number of disks, from sda to sdp, while there is only one disk and one tape
station attached in reality.

It is in some way related to the amount of memory.  The machine has 4 GB.  In
BIOS there is an option to remap the last GB to between 4 and 5 GB.  The
behaviour I describe happens when this option is enabled.  If disabled, the
module works normally, but Linux sees only 3 GB.  This also happens if I say
mem=4G on the boot command line.

Version-Release number of selected component (if applicable):
2.6.12-1.1398_FC4smp

How reproducible:
Every time (When expermimenting with unloading and loading the module it once
didn't show all those devices.  But then the partition table of the only real
disk was unreadable.  I haven't been able to repeat this; I don't know what I
did different that time.)
Comment 1 Göran Uddeborg 2005-08-29 15:54:01 EDT
Created attachment 118223 [details]
Boot log from /var/log/messages
Comment 2 Göran Uddeborg 2005-08-29 15:55:37 EDT
Created attachment 118224 [details]
Output of "lsmod"
Comment 3 Dave Jones 2005-08-29 20:06:35 EDT
Can you unplug the tape station, and see if that makes the problem go away ?
Comment 4 Göran Uddeborg 2005-08-30 05:40:55 EDT
I tried unplugging the tape station, but it didn't make any difference.  I also
tried to upgrade to kernel-smp-2.6.12-1.1447_FC4, but that also didn't make any
difference.
Comment 5 Dave Jones 2005-08-30 15:09:07 EDT
I have a patch that may fix this, I'll roll it into a test kernel later today.
Comment 6 Göran Uddeborg 2005-09-01 03:15:52 EDT
Without being sure what timezone "today" in comment 5 applies to :-), it should
have passed by now under all circumstances.  But can't find any new kernel, or
any kernel for that matter, in updates-testing.  (I looked directly in
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/x86_64/)

Is it just delayed for some reason?  (Maybe there is some delay before it
becomes available, or maybe you just couldn't make it for whatever reason.)  Or
am I looking in the wrong place?
Comment 7 Dave Jones 2005-09-05 02:49:49 EDT
argh. I thought I included this in the 1450 kernel I pushed to updates-testing
(which hasn't actually got pushed out yet).  I've just added it to CVS. I'll see
if I can get a 1451 built & pushed out before anyone pushes it :-)
Comment 8 Dave Jones 2005-09-12 01:44:24 EDT
Can you test the 1454 kernel from 
http://people.redhat.com/davej/kernels/Fedora/FC4/

and report back your results please ?

Thanks.
Comment 9 Göran Uddeborg 2005-09-12 10:21:33 EDT
It looks good.  The new kernel found only existing devices during the boot, and
I could run fdisk and mkfs on the attached disk.  I'll check the tape drive
later, but having come this far, I don't expect any problems.

(This done with all 4 GB enabled, obviously.)
Comment 10 Göran Uddeborg 2005-09-12 16:03:29 EDT
But the new kernel crashed after a couple of hours.

Previous kernels have also been unstable when running with 4 GB.  I thought that
was some kind of consequence of the misbehaving SCSI module.  But it appears it
is a separate problem.  I haven't seen any problems when running and only using
3 GB.  Memtest is happy with all 4 GB.

I'll try to set up netdump, and file a separate case about this.  But I thought
I'd mention it here too, in case there might be some kind of connection after all.
Comment 11 Göran Uddeborg 2005-09-18 17:45:14 EDT
I've now filed bug 168643 about the unstableness problem.
Comment 12 Dave Jones 2005-09-23 19:36:45 EDT
ok, with this patch now pushed out to updates, I'll close this issue, and we'll
use the other bug to track the instability.

Thanks for testing.
Comment 13 Fedora Update System 2005-09-29 23:12:09 EDT
From User-Agent: XML-RPC

kernel-2.6.13-1.1526_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.