Bug 168643 - Using 4 GB makes kernel unstable
Using 4 GB makes kernel unstable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-18 17:43 EDT by Göran Uddeborg
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 19:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Crash log (593 bytes, text/plain)
2005-09-18 17:43 EDT, Göran Uddeborg
no flags Details

  None (edit)
Description Göran Uddeborg 2005-09-18 17:43:41 EDT
Description of problem:
On a newly installed system with a dual core Athlon 64 and 4 GB of memory, the
system runs fine as long as I constrain it to 3 GB (mem=3G on boot line).  When
I remove the restriction, it first starts up fine, but crash shortly.  Typically
when it starts to get a little bit loaded.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.12-1.1454_FC4

How reproducible:
It doesn't happen on any particular command.  But it does not ever take too long
before it happens.

Additional info:
This is the same system for which I reported problems in the SCSI driver in bug
167049.  I first believed the unstableness to be some side-effect of the other
bug.  But with the 2.6.12-1.1454_FC4 kernel the SCSI driver acts correctly, but
the system is still unstable with 4 GB.  So I assume there are two different
bugs here.

I've now set up netdump to get a chance to know what is going on.  At first it
didn't produce anything at all.  On the console it said something about netdump
being entered recursively.  Now I've been able to at least catch a little log,
which I enclose.  It is very short and I don't really expect it to say anything
to anybody, but just in case I submit it anyway.

I'll continue to try to get more information to attach.  Since we can't wait to
get the machine in production any longer, it might take some time before I can
continue expermentation.
Comment 1 Göran Uddeborg 2005-09-18 17:43:41 EDT
Created attachment 118952 [details]
Crash log
Comment 2 Dave Jones 2005-09-23 18:33:52 EDT
can you try the 2.6.13-1.1524_FC4 kernel in updates-testing ?
Comment 3 Dave Jones 2005-09-23 18:35:01 EDT
actually, scrap that. it's missing the previous AIC fix I had you test.
I'll rebuild another test kernel soon.
Comment 4 Dave Jones 2005-09-23 18:38:14 EDT
ok, 1525 will appear at http://people.redhat.com/davej/kernels/Fedora/FC4/
in a little while. Please let me know how that works out.
Comment 5 Göran Uddeborg 2005-09-24 14:08:31 EDT
2.6.13 :-)

I've downloaded it, and will find an opportunity to test it out during the
coming week.
Comment 6 Göran Uddeborg 2005-09-27 06:37:58 EDT
It is looking good.  The machine has been running for more than 13 hours now
with 2.6.13-1.1525_FC4smp.  It never took that long to crash it before.  I
believe it works now.
Comment 7 Dave Jones 2005-09-27 18:19:18 EDT
thanks for testing. I'll put this in modified state until that update gets
pushed live, which will hopefully happen quite soon.
Comment 8 Dave Jones 2005-09-30 02:01:38 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Göran Uddeborg 2005-10-03 17:49:16 EDT
As I said in comment 6 my problems were fixed already in 2.6.13-1.1525_FC4.  But
I can confirm that 2.6.13-1.1526_FC4 runs fine too.

Note You need to log in before you can comment on or make changes to this bug.