Bug 1670551 - oc image mirror fails with error 'tag: unexpected end of JSON input' when trying to mirror image from Red Hat registry.
Summary: oc image mirror fails with error 'tag: unexpected end of JSON input' when try...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.11.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.11.z
Assignee: Ben Parees
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1668233 1676404
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-29 19:32 UTC by Ben Parees
Modified: 2019-02-20 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Commits from a dependency were dropped from the product build Consequence: The oc image mirror command was unable to parse the output of the redhat registry Fix: The commits were reintroduced Result: The command can now parse the output and successfully mirror from the redhat registry
Clone Of: 1668233
Environment:
Last Closed: 2019-02-20 14:11:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0326 None None None 2019-02-20 14:11:14 UTC

Comment 1 Ben Parees 2019-01-29 19:33:53 UTC
https://github.com/openshift/origin/pull/21887

Comment 3 XiuJuan Wang 2019-02-11 08:03:01 UTC
Can't reproduce this issue with below version
$./oc version 
oc v3.11.82
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ec2-34-229-248-85.compute-1.amazonaws.com:443
openshift v3.11.82
kubernetes v1.11.0+d4cacc0

$./oc image mirror  registry.access.redhat.com/openshift3/jenkins-2-rhel7:v3.11 docker.io/xiuwang/jenkins-2-rhel7:v3.11
docker.io/
  xiuwang/jenkins-2-rhel7
    blobs:
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:c9d123037991e434b21f9721aa46f6808fd4adb212ae3ca1d7263623f645cf2d 1.2KiB
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:476ab469e17b55efdb3589ffc51f95926e6b962fa3fb1bb77b273f86b5f9729a 4.569KiB
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:f66e168c604d40a7bd6b5c81242c2d0fbba44a560c7c9b784b2a7e73bec2c603 7.134MiB
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:32fa1db9700818daf860c4fcfa82332337210f2767a84414ec40b200fe927ea2 32.02MiB
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:c325120ebc8d0e6d056a7b3ca1ba9f5cf9e2d48e6bbca1f9cd8492d7f0674008 72.25MiB
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:be8b7fd56d4f10a8df76d19690f395a21af47ec4e56a740c7b0c9daebc0c918a 100.7MiB
      registry.access.redhat.com/openshift3/jenkins-2-rhel7 sha256:201a8ec411147662449a8269ee8c52275c6d291a261d25a2a6799bf1845522a5 327.6MiB
    manifests:
      sha256:36f8501570cd2846cc93f34a53010f3971803876bf11362399267fcd0368feb2 -> v3.11
  stats: shared=0 unique=7 size=539.7MiB ratio=1.00

phase 0:
  docker.io xiuwang/jenkins-2-rhel7 blobs=7 mounts=0 manifests=1 shared=0

info: Planning completed in 7.61s
uploading: docker.io/library/xiuwang/jenkins-2-rhel7 sha256:32fa1db9700818daf860c4fcfa82332337210f2767a84414ec40b200fe927ea2 32.02MiB
uploading: docker.io/library/xiuwang/jenkins-2-rhel7 sha256:c325120ebc8d0e6d056a7b3ca1ba9f5cf9e2d48e6bbca1f9cd8492d7f0674008 72.25MiB
uploading: docker.io/library/xiuwang/jenkins-2-rhel7 sha256:be8b7fd56d4f10a8df76d19690f395a21af47ec4e56a740c7b0c9daebc0c918a 100.7MiB
uploading: docker.io/library/xiuwang/jenkins-2-rhel7 sha256:f66e168c604d40a7bd6b5c81242c2d0fbba44a560c7c9b784b2a7e73bec2c603 7.134MiB
uploading: docker.io/library/xiuwang/jenkins-2-rhel7 sha256:201a8ec411147662449a8269ee8c52275c6d291a261d25a2a6799bf1845522a5 327.6MiB
sha256:36f8501570cd2846cc93f34a53010f3971803876bf11362399267fcd0368feb2 docker.io/library/xiuwang/jenkins-2-rhel7:v3.11
info: Mirroring completed in 10m24.71s (905.9kB/s)

Comment 5 errata-xmlrpc 2019-02-20 14:11:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0326


Note You need to log in before you can comment on or make changes to this bug.