Bug 1670713 - Could not drag environment vars on Firefox
Summary: Could not drag environment vars on Firefox
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1688679 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-30 08:56 UTC by Yanping Zhang
Modified: 2019-05-06 13:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-22 12:51:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yanping Zhang 2019-01-30 08:56:53 UTC
Description of problem:
Open admin console with Firefox, try to drag and drop environment vars on environment tab of dc page, could not drag successfully.

Version-Release number of selected component (if applicable):
io.openshift.build.commit.url=https://github.com/openshift/console/commit/5070df1f11d481f36152c0218f209a085eed9d64
Firefox 64

How reproducible:
Always

Steps to Reproduce:
1.Login admin console on Firefox 64. Create dc in project, add several environment vars for dc.
2. Drag and drop environment vars on environment tab of dc page
3.

Actual results:
2. Could not drag successfully.

Expected results:
2. Should succeed to drag env vars.

Additional info:

Comment 1 Joe Caiani 2019-01-31 22:18:45 UTC
I was able to reproduce the drag and drop issue stated in the bug.

I upgraded react-dnd and react-dnd-html-backend packages from the existing version (2.6.0) to the latest version (7.0.2) with no change in behavior on firefox as the issue still exists.

Noted another issue in react-dnd having to do with firefox:
-https://github.com/react-dnd/react-dnd/issues/869

Comment 3 Joe Caiani 2019-04-18 20:50:05 UTC
The issue in firefox has been resolved by the firefox team. The drag and drop components work in FF 64 Bit: V66.03 and later. This was not an issue with the console code.

Comment 4 Yadan Pei 2019-04-19 02:01:00 UTC
Upgraded Firefox to v66.0.2 (64-bit), the issue has been fixed.

Move to VERIFIED

Comment 5 Yadan Pei 2019-04-22 09:46:05 UTC
*** Bug 1688679 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.