Bug 1670772 - cluster-image-registry-operator shows Updating state with a failed message
Summary: cluster-image-registry-operator shows Updating state with a failed message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Ben Parees
QA Contact: Wenjing Zheng
URL:
Whiteboard:
: 1671175 (view as bug list)
Depends On:
Blocks: 1664187
TreeView+ depends on / blocked
 
Reported: 2019-01-30 10:23 UTC by Jaspreet Kaur
Modified: 2019-06-04 10:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:36 UTC

Description Jaspreet Kaur 2019-01-30 10:23:31 UTC
Description of problem:When checking the state of cluster operator it shows
cluster-image-registry-operator as  Updating


Unable to apply resources: unable to apply objects: failed to create object *v1.Image, Name=cluster: images.config.openshift.io "cluster" is invalid: metadata.resourceVersion: Invalid value: 0x0: must be specified for an update
v4.0.0-0.148.0.0-dirty

oc describe clusteroperator cluster-image-registry-operator

Name:         cluster-image-registry-operator
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-01-28T06:19:53Z
  Generation:          1
  Resource Version:    12130
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/cluster-image-registry-operator
  UID:                 b981cce3-22c4-11e9-add3-06c4c3807714
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-01-28T06:24:54Z
    Message:               Deployment does not exist
    Status:                False
    Type:                  Available
    Last Transition Time:  2019-01-28T06:24:54Z
    Message:               Unable to apply resources: unable to apply objects: failed to create object *v1.Image, Name=cluster: images.config.openshift.io "cluster" is invalid: metadata.resourceVersion: Invalid value: 0x0: must be specified for an update
    Status:                True
    Type:                  Progressing
    Last Transition Time:  2019-01-28T06:24:54Z
    Status:                False
    Type:                  Failing
  Extension:               <nil>
  Version:                 v4.0.0-0.148.0.0-dirty
Events:                    <none>

oc get crd images.config.openshift.io -o yaml
apiVersion: apiextensions.k8s.io/v1beta1
kind: CustomResourceDefinition
metadata:
  creationTimestamp: 2019-01-28T06:19:46Z
  generation: 1
  name: images.config.openshift.io
  resourceVersion: "6000"
  selfLink: /apis/apiextensions.k8s.io/v1beta1/customresourcedefinitions/images.config.openshift.io
  uid: b5b91d21-22c4-11e9-add3-06c4c3807714
spec:
  additionalPrinterColumns:
  - JSONPath: .metadata.creationTimestamp
    description: |-
      CreationTimestamp is a timestamp representing the server time when this object was created. It is not guaranteed to be set in happens-before order across separate operations. Clients may not set this value. It is represented in RFC3339 form and is in UTC.

      Populated by the system. Read-only. Null for lists. More info: https://git.k8s.io/community/contributors/devel/api-conventions.md#metadata
    name: Age
    type: date
  group: config.openshift.io
  names:
    kind: Image
    listKind: ImageList
    plural: images
    singular: image
  scope: Cluster
  subresources:
    status: {}
  version: v1
  versions:
  - name: v1
    served: true
    storage: true
status:
  acceptedNames:
    kind: Image
    listKind: ImageList
    plural: images
    singular: image
  conditions:
  - lastTransitionTime: 2019-01-28T06:19:46Z
    message: no conflicts found
    reason: NoConflicts
    status: "True"
    type: NamesAccepted
  - lastTransitionTime: null
    message: the initial names have been accepted
    reason: InitialNamesAccepted
    status: "True"
    type: Established
  storedVersions:
  - v1



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:  failed updating state of clusteroperator image-registry


Expected results: New installation should show running state instead of updating failed state of cluster operator


Additional info:

Comment 2 Ben Parees 2019-01-31 02:34:01 UTC
*** Bug 1671175 has been marked as a duplicate of this bug. ***

Comment 3 Wenjing Zheng 2019-02-19 06:07:00 UTC
No such issue now: 
Status:
  Conditions:
    Last Transition Time:  2019-02-18T08:08:23Z
    Message:               Deployment has minimum availability
    Status:                True
    Type:                  Available
    Last Transition Time:  2019-02-19T03:48:25Z
    Message:               Everything is ready
    Status:                False
    Type:                  Progressing
    Last Transition Time:  2019-02-18T04:12:53Z
    Status:                False
    Type:                  Failing
  Extension:               <nil>
  Related Objects:         <nil>
  Versions:
    Name:     operator
    Version:  v4.0.0-0.174.0.0-dirty
Events:       <none>

Comment 6 errata-xmlrpc 2019-06-04 10:42:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.