Bug 1671175 - registry clusterversion says not available
Summary: registry clusterversion says not available
Keywords:
Status: CLOSED DUPLICATE of bug 1670772
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ben Parees
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-31 00:10 UTC by Eric Paris
Modified: 2019-01-31 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 02:34:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
logs from cluster-image-registry-operator (106.71 KB, text/plain)
2019-01-31 00:10 UTC, Eric Paris
no flags Details
$ oc -n openshift-image-registry describe deployment image-registry (3.34 KB, text/plain)
2019-01-31 00:12 UTC, Eric Paris
no flags Details
oc describe of the registry pod, and all of the events in the ns (4.91 KB, text/plain)
2019-01-31 00:16 UTC, Eric Paris
no flags Details

Description Eric Paris 2019-01-31 00:10:08 UTC
$ oc get clusteroperator
NAME                                    VERSION                      AVAILABLE   PROGRESSING   FAILING   SINCE
cluster-autoscaler-operator             v4.0.0-0.148.0.0-dirty       True        False         False     6h
cluster-image-registry-operator         v4.0.0-0.148.0.0-dirty       False       True          False     6h
cluster-monitoring-operator                                          True        False         False     2h
kube-controller-manager                                              True        False         False     6h
machine-api-operator                    v4.0.0-0.148.0.0-dirty       True        False         False     2m
machine-config-operator                 4.0.0-0.148.0.0-dirty        True        False         False     7s
openshift-apiserver                                                  True        False         False     11m
openshift-cluster-samples-operator      v4.0.0-0.148.0.0-3959b9dec   True        False         False     6h
openshift-controller-manager-operator                                True        False         False     1m
openshift-dns-operator                  0.0.1                        True        False         False     6h
openshift-ingress-operator              0.0.1                        True        False         False     6h
openshift-kube-apiserver-operator                                    True        False         False     6h
openshift-kube-scheduler-operator                                    True        False         False     0s

$ oc describe clusteroperator cluster-image-registry-operator
Name:         cluster-image-registry-operator
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  config.openshift.io/v1
Kind:         ClusterOperator
Metadata:
  Creation Timestamp:  2019-01-30T17:44:23Z
  Generation:          1
  Resource Version:    11610
  Self Link:           /apis/config.openshift.io/v1/clusteroperators/cluster-image-registry-operator
  UID:                 ae3922eb-24b6-11e9-bf12-0efa58db9582
Spec:
Status:
  Conditions:
    Last Transition Time:  2019-01-30T17:49:25Z
    Message:               Deployment does not exist
    Status:                False
    Type:                  Available
    Last Transition Time:  2019-01-30T17:49:25Z
    Message:               Unable to apply resources: unable to apply objects: failed to create object *v1.Image, Name=cluster: images.config.openshift.io "cluster" is invalid: metadata.resourceVersion: Invalid value: 0x0: must be specified for an update
    Status:                True
    Type:                  Progressing
    Last Transition Time:  2019-01-30T17:49:25Z
    Status:                False
    Type:                  Failing
  Extension:               <nil>
  Version:                 v4.0.0-0.148.0.0-dirty
Events:                    <none>

Comment 1 Eric Paris 2019-01-31 00:10:48 UTC
Created attachment 1525196 [details]
logs from cluster-image-registry-operator

Comment 2 Eric Paris 2019-01-31 00:12:43 UTC
Created attachment 1525197 [details]
$ oc -n openshift-image-registry describe deployment image-registry

Comment 3 Eric Paris 2019-01-31 00:16:06 UTC
Created attachment 1525198 [details]
oc describe of the registry pod, and all of the events in the ns

Comment 4 Ben Parees 2019-01-31 02:34:01 UTC

*** This bug has been marked as a duplicate of bug 1670772 ***


Note You need to log in before you can comment on or make changes to this bug.