Bug 167088 - scim huge delay with rhgb
scim huge delay with rhgb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2005-08-30 01:41 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: scim-1.4.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 02:40:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2005-08-30 01:41:24 EDT
If scim is installed, rhgb gets stuck for up to 1 minute and 42 seconds before
doing anything during bootup.  This problem manifests due to this bug in scim,
and also the unpredictable behavior of what GTK+ immodule is chosen when
GTK_IM_MODULE is unset.

Reproduce Procedure:
1. Install scim on RHEL4, FC3, FC4, or FC5.
2. Boot with rhgb in the kernel boot options.
3. Watch as X is stuck for up to 1 minute and 42 seconds.

If you export GTK_IM_MODULE=gtk-im-context-simple in rc.sysinit before it runs
rhgb, it works around this problem by avoiding loading of scim immodule, but
this of course is not a good solution.

Version-Release number of selected component (if applicable):
scim-1.4.2-0
Comment 1 Warren Togami 2005-08-30 02:36:53 EDT
http://people.redhat.com/wtogami/archive/2005/bootchart-unset.svgz
bootchart revealing that scim is causing the huge delay during bootup.
http://people.redhat.com/wtogami/archive/2005/bootchart-set-simple.svgz
export GTK_IM_MODULE=gtk-im-context-simple in rc.sysinit before rhgb is launched
hides the problem, as would the proposed solution to Bug #167090.
Comment 2 Warren Togami 2005-08-30 03:01:44 EDT
Bug #167090 is the GTK_IM_MODULE problem, when solved will unfortunately only
hide this problem.  This problem itself must be investigated in order to be sure
it wont cause defects during regular desktop operation, firstboot, or other uses
of GTK+.
Comment 3 Jens Petersen 2005-09-01 23:03:14 EDT
Warren commented the other day that this may be due to scim being
launched while the root filesystem is still mounted read-only.
Comment 4 Jens Petersen 2005-09-02 00:48:14 EDT
Added a patch in scim-1.4.2-2 to set the gtk immodule lang list empty.
Comment 5 Warren Togami 2005-09-03 06:42:44 EDT
Actually making the lang list empty is the solution that we agreed upon for Bug
#167090.  That change does effectively negate the huge rhgb delay problem which
was probably our most serious bug.

This bug is a different issue where scim gets stuck for a long time if it cannot
create its sockets.  I think we should make scim fail immediately rather than
wait such a long time.  Resetting to FC5Target, this is a lower priority issue now.
Comment 6 Warren Togami 2005-09-08 06:54:28 EDT
Hmm... I think I was wrong about r/o filesystem being the cause of this problem.
 By the time rhgb runs here, the root is already remounted r/w.  While we are
avoiding this problem with the immodule language removal, we should still figure
out the cause.
Comment 8 Warren Togami 2005-12-20 09:00:27 EST
A more recent version of SCIM no longer enables IM in GTK+ password dialogs, so
there are now two things preventing this from happening in gnome-ssh-askpass.  I
suppose this is only a symptom of the debug prints going to stdout combined with
the crap redirection used by askpass.  Hopefully nothing else is affected by
this.  So closing...
Comment 9 Warren Togami 2005-12-20 14:36:21 EST
oops, the password dialog thing was meant for Bug #168654.  This might still be
a problem... retesting.
Comment 10 Jens Petersen 2006-04-27 02:40:01 EDT
Closing for now.  Please reopen if the problem occurs again.

Note You need to log in before you can comment on or make changes to this bug.