Bug 167089 - /proc/acpi/button no longer there
/proc/acpi/button no longer there
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 167655 (view as bug list)
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-30 01:49 EDT by Walter Neumann
Modified: 2015-01-04 17:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 08:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Neumann 2005-08-30 01:49:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
acpid scripts that depend on the lid status fail since the directory
/proc/acpi/lid has disappeared in the upgrade from 2.6.12-1.1398_FC4 to 2.6.12-1.1447_FC4 .

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1.boot kernel 2.6.12-1.1447_FC4 with acpi enabled
2.
3.
  

Actual Results:  The directory /proc/acpi/lid is missing. Previous kernels provided
/proc/acpi/lid/LID/state which recorded if the lid was open or shut on a laptop. 
Scripts that depend on this therefore now fail.

Expected Results:  /proc/acpi/lid/LID/state should exist and give lid state.

Additional info:
Comment 1 Walter Neumann 2005-08-30 01:58:18 EDT
Correction : /proc/acpi/button/
is the missing directory that contained /proc/acpi/button/lid/LID/state 
in previous kernels
Comment 2 Alexey Starikovskiy 2005-08-30 09:45:16 EDT
2.6.13 should have /proc/acpi/button again
Comment 3 Seva 2005-08-31 00:00:46 EDT
/proc/acpi/sleep and /proc/acpi/ibm are missing as well after the same upgrade
Comment 4 Ariel T. Glenn 2005-09-11 16:28:14 EDT
http://bugzilla.kernel.org/show_bug.cgi?id=4988 claims that 2.6.13-rc6 has the
fix, if fedora folks don't want to jump to 2.6.13
Comment 5 Mace Moneta 2005-09-15 23:06:47 EDT
The same problem exists in recent FC3 kernels, though 2.6.12-1.1378_FC3.
Comment 6 Dave Jones 2005-09-28 06:09:04 EDT
*** Bug 167655 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2005-09-28 06:10:08 EDT
this is fixed in the current fc4-updates-testing kernel.
Comment 8 Dave Jones 2005-09-30 02:59:43 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Walter Neumann 2005-09-30 07:28:09 EDT
Fixed for me in 2.6.13-1.1526_FC4

Note You need to log in before you can comment on or make changes to this bug.