Bug 167655 - /proc/acpi/button directory missing with kernel-2.6.12-1.1447_FC4
/proc/acpi/button directory missing with kernel-2.6.12-1.1447_FC4
Status: CLOSED DUPLICATE of bug 167089
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-09-06 13:13 EDT by Thomas J. Baker
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 06:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2005-09-06 13:13:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050827 Fedora/1.1-0.2.8.deerpark.alpha2 Firefox/1.0+

Description of problem:
Booting the kernel-2.6.12-1.1447_FC4 on my Dell Inspiron 600m, the /proc/acpi/button directory is missing, which contains the lid and power button states. Booting the previous kernel-2.6.12-1.1398_FC4 returns things to normal. 

The kernel messages look normal:

ACPI: AC Adapter [AC] (on-line)
Using generic hotkey driver
ACPI: Battery Slot [BAT0] (battery present)
ACPI: Battery Slot [BAT1] (battery absent)
ACPI: Lid Switch [LID]
ACPI: Power Button (CM) [PBTN]
ACPI: Sleep Button (CM) [SBTN]
ibm_acpi: Using generic hotkey driver
toshiba_acpi: Using generic hotkey driver
ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)

but the /proc/acpi/button directory is not created.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1.boot new kernel
2.
3.
  

Additional info:
Comment 1 Thomas J. Baker 2005-09-12 11:19:15 EDT
The 1450 kernel from updates-testing does not restore the /proc/acpi/button
directory when booted.
Comment 2 Robert Bertram 2005-09-20 06:57:21 EDT
I have this as well. 
Comment 3 Robert Bertram 2005-09-20 07:02:41 EDT
(In reply to comment #2)
> I have this as well. 

Sorry. Just to be clear, I have this problem as well.
Comment 4 Thomas J. Baker 2005-09-23 16:11:54 EDT
kernel 1456 just released also has this lack of a /proc/acpi/button directory.
Comment 5 Dave Jones 2005-09-23 16:48:42 EDT
this should be fixed in the 2.6.13-1.1524_FC4 just pushed to updates-testing
Comment 6 Robert Bertram 2005-09-23 23:57:06 EDT
(In reply to comment #5)
> this should be fixed in the 2.6.13-1.1524_FC4 just pushed to updates-testing

Yes it fixes it. My lid close script work again. 

But brings up a couple of other problems. PCMCIA service has a problem and I
can't get the latest intel wireless driver to install. Do these need a new bug
report?

[root@eyrie ~]# service pcmcia restart
Shutting down PCMCIA services: done.
Starting PCMCIA services: cardmgr[8375]: watching 1 socket
cardmgr[8375]: could not adjust resource: IO ports 0x3d3-0x3d3: Input/output error
done.

CONFIG_IEEE80211_CRYPT_CCMP=m
CONFIG_IEEE80211_CRYPT_TKIP=m
Above definitions found.  Comment out? [y], n y
sed: can't read /lib/modules/2.6.13-1.1524_FC4/build//build/.config: No such fil
e or directory
Comment 7 Dave Jones 2005-09-24 01:39:46 EDT
Please file a separate bug for the pcmcia problem.

The build//build looks funny, and looks like a bug in the ipw folks
configuration script. You may want to bring that up with them upstream.
Comment 8 Thomas J. Baker 2005-09-24 08:30:42 EDT
The 1524 kernel does indeed restore the /proc/acpi/button. I did see the same
pcmcia error too.
Comment 9 Robert Bertram 2005-09-26 06:45:39 EDT
Ok I added Bug 169268 as a kernel bug in regard to pcmcia. Hope that ok. 

I look at the wireless problem a bit more. Something odd there though normal its
not a problem to get it working.

Comment 10 Dave Jones 2005-09-28 06:08:48 EDT

*** This bug has been marked as a duplicate of 167089 ***

Note You need to log in before you can comment on or make changes to this bug.