Bug 167122 - ps2pdf does not work properly w.r.t. font metrics
ps2pdf does not work properly w.r.t. font metrics
Status: CLOSED DUPLICATE of bug 140584
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: urw-fonts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-08-30 12:16 EDT by Jos Vos
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-06 07:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Sample PS file showing the problem (219 bytes, text/plain)
2005-08-30 12:16 EDT, Jos Vos
no flags Details

  None (edit)
Description Jos Vos 2005-08-30 12:16:14 EDT
Description of problem:
When using the Courier font in a PS file, the font metrics seem to be broken in
some way, so the output of ps2pdf is wrong.

Version-Release number of selected component (if applicable):

How reproducible:
See the attached small test.ps file.

Steps to Reproduce:
1. ps2pdf -sPAPERSIZE=a4 test.ps
2. look at test.pdf with a PDF reader
3. the "Test Courier" text *should* immediately be followed by the "Test Times
2" text.
Additional info:
Attached a sample PS file.  This sample works fine with older Ghostscript
versions, like 5.x.
Comment 1 Jos Vos 2005-08-30 12:16:14 EDT
Created attachment 118255 [details]
Sample PS file showing the problem
Comment 2 Jos Vos 2005-08-30 12:25:28 EDT
It also works ok on RHEL3 with Ghostscript 7.05-32.1.9.
Comment 3 Tim Waugh 2005-09-05 08:10:14 EDT
What version of urw-fonts do you have installed?
Comment 4 Jos Vos 2005-09-05 08:13:43 EDT
This is with urw-fonts version 2.2-6.
Comment 5 Tim Waugh 2005-09-06 06:40:49 EDT
Known urw-fonts bug.  See bug #140584.
Comment 6 Ngo Than 2005-09-06 07:43:06 EDT

*** This bug has been marked as a duplicate of 140584 ***
Comment 7 Jos Vos 2005-09-06 08:04:01 EDT
It might be more appropriate to refer to bug #161434 here (I just found that),
which is a RHEL4 bug that is said to be fixed in an errata version (which will
be in U2 as far as I can see), as linking to a FC bug does not tell a lot about
when this will be solved in RHEL4.

Note You need to log in before you can comment on or make changes to this bug.