This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 167240 - toshiba_acpi appears to be broken in 2.6.12-1.1376_FC3
toshiba_acpi appears to be broken in 2.6.12-1.1376_FC3
Status: CLOSED DUPLICATE of bug 167218
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-31 16:35 EDT by Radek Bíba
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 16:42:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2005-08-31 16:35:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
With kernel-2.6.12-1.1372_FC3, toshiba_acpi is working, but after upgrade to
rnel-2.6.12-1.1376_FC3 and reboot, it fails to load, saying No such device.
FnFXd, a daemon for managing the Fn key, used for brightness control, sleeping
and so on doesn't work either, since it requires toshiba_acpi to be loaded.

When I boot the previous version, kernel-2.6.12-1.1372_FC3, the module works and
so does FnFXd.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1376_FC3

How reproducible:
Always

Steps to Reproduce:
1. Grab a recent Toshiba laptop (with Toshiba BIOS)
2. Install kernel-2.6.12-1.1376_FC3,
3. Reboot
3. when using FnFX, an error message will be printed as soon as it starts,
otherwise search for /proc/acpi/toshiba - should be loaded out of thebox, or
try modprobe toshiba_acpi
  

Actual Results:  toshiba_acpi isn't loaded, saying No such device

Expected Results:  toshiba_acpi just works with a Toshiba laptop, as did previously

Additional info:
Comment 1 Radek Bíba 2005-08-31 16:42:03 EDT
Oops, Reload isn't the right button to use when one wants to refresh the page
with newly created bug report :)

*** This bug has been marked as a duplicate of 167218 ***

Note You need to log in before you can comment on or make changes to this bug.