Bug 167218 - toshiba_acpi appears to be broken in 2.6.12-1.1376_FC3
toshiba_acpi appears to be broken in 2.6.12-1.1376_FC3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 167240 (view as bug list)
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-31 13:17 EDT by Radek Bíba
Modified: 2015-01-04 17:21 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.12-1.1380_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 12:55:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2005-08-31 13:17:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
With kernel-2.6.12-1.1372_FC3, toshiba_acpi is working, but after upgrade to
rnel-2.6.12-1.1376_FC3 and reboot, it fails to load, saying No such device.
FnFXd, a daemon for managing the Fn key, used for brightness control, sleeping
and so on doesn't work either, since it requires toshiba_acpi to be loaded.

When I boot the previous version, kernel-2.6.12-1.1372_FC3, the module works and
so does FnFXd.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1376_FC3

How reproducible:
Always

Steps to Reproduce:
1. Grab a recent Toshiba laptop (with Toshiba BIOS)
2. Install kernel-2.6.12-1.1376_FC3,
3. Reboot
3. when using FnFX, an error message will be printed as soon as it starts,
otherwise search for /proc/acpi/toshiba - should be loaded out of thebox, or
try modprobe toshiba_acpi
  

Actual Results:  toshiba_acpi isn't loaded, saying No such device

Expected Results:  toshiba_acpi just works with a Toshiba laptop, as did previously

Additional info:
Comment 1 Radek Bíba 2005-08-31 16:42:22 EDT
*** Bug 167240 has been marked as a duplicate of this bug. ***
Comment 2 Andreas Müller 2005-09-01 04:31:37 EDT
I've cloned this bug for FC4, which has the same problem with
kernel-2.6.12-1.1447_FC4, Bug #167281
Comment 3 Mace Moneta 2005-09-15 19:13:28 EDT
I checked kernel-2.6.12-1.1378_FC3 (since CVS noted the
linux-2.6-acpi-rollup-20050902.patch is included), and the same problem exists.
Comment 4 Mace Moneta 2005-09-15 20:29:22 EDT
Kernel bug 4953 appears to address this:

http://bugzilla.kernel.org/show_bug.cgi?id=4953

There is a patch (for 2.6.13-rc6), as well as a workaround (adding kernel
parameter acpi_specific_hotkey).

Comment 5 Radek Bíba 2005-09-19 03:05:03 EDT
Confirming, kernel parameter acpi_specific_hotkey added to kernel
(2.6.12-1.1376_FC3) command line solves the problem for the time being.
Thanks Mace!
Comment 6 Dave Jones 2005-09-23 21:53:25 EDT
fixed in cvs. will be in next update.
 
Comment 7 Fedora Update System 2005-10-20 10:30:07 EDT
From User-Agent: XML-RPC

kernel-2.6.12-1.1380_FC3 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 8 Radek Bíba 2005-10-20 12:55:26 EDT
Confirming fix, thanks. acpi_specific_hotkey is no longer needed.

Note You need to log in before you can comment on or make changes to this bug.