Bug 167281 - toshiba_acpi appears to be broken in 2.6.12-1.1447_FC4
toshiba_acpi appears to be broken in 2.6.12-1.1447_FC4
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-09-01 04:24 EDT by Andreas Müller
Modified: 2015-01-04 17:21 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.13-1.1526_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 07:09:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andreas Müller 2005-09-01 04:24:11 EDT
+++ This bug was initially created as a clone of Bug #167218 +++

Description of problem:
With kernel-2.6.12-1.1398_FC4, toshiba_acpi is working, but after upgrade to
kernel-2.6.12-1.1447_FC4 and reboot, it fails to load, saying No such device.
FnFXd, a daemon for managing the Fn key, used for brightness control, sleeping
and so on doesn't work either, since it requires toshiba_acpi to be loaded.

When I boot the previous version, kernel-2.6.12-1.1398_FC4, the module works and
so does FnFXd.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1. Grab a recent Toshiba laptop (with Toshiba BIOS)
2. Install kernel-2.6.12-1.1447_FC4,
3. Reboot
4. when using FnFX, an error message will be printed as soon as it starts,
otherwise search for /proc/acpi/toshiba - should be loaded out of thebox, or
try modprobe toshiba_acpi
  

Actual Results:  toshiba_acpi isn't loaded, saying No such device

Expected Results:  toshiba_acpi just works with a Toshiba laptop, as did previously
Comment 1 wilksen 2005-09-02 01:13:07 EDT
Same is true for - probably all - IBM Thinkpads. IBM hot buttons do not work
anymore. Loading the ibm_acpi.ko module results in the same error as for the
toshiba_acpi that there's no such device. I guess, this is a result of disabling
the hotkeys in the configuration for the 2.6.12-1.1447 kernel. But the ibm_acpi
module and the hotkey driver were working fine with 2.6.12-1.1398. Actually 
related to that, acpi resume is broken now with 2.6.12-1.1447 for a T22 Thinkpad.
Comment 2 Mike Basinger 2005-09-12 13:05:49 EDT
Same problem here
Comment 3 Richard Hughes 2005-09-21 19:35:34 EDT
Yes, I have quite a few reports of this "broken kernel" breaking the GNOME Power
Manager on FC4. My rawhide image (2.6.13-1.1565_FC5) has no such breakage, but I
appreciate going from 2.6.12 -> 2.6.13 would cause lots of userspace breakage in
a stable FC version. Could we no backport the ACPI patch from 2.6.13 into the
FC4 errata kernel? Many thanks.
Comment 4 Jared Smith 2005-09-22 13:58:21 EDT
I'm not sure this comment really belongs to this bug, but I'm also having
massive ACPI problems on 2.6.12-1.1447 with an HP nc6320.  Going back to
2.6.12-1.1398 seems to solve my problems.
Comment 5 Dave Jones 2005-09-23 21:54:09 EDT
this should be fixed in the next update.. 
You can test this by grabbing the 2.6.13-1.1524 kernel from updates-testing.
Comment 6 Andreas Müller 2005-09-24 05:53:57 EDT
2.6.13-1.1524 works for me (on Toshiba Satellite Pro M10)

When will we see this kernel in updates?
Comment 7 Richard Hughes 2005-09-25 11:54:39 EDT
Works for me too.
Comment 8 Dave Jones 2005-09-30 03:02:15 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Andreas Müller 2005-10-03 07:09:40 EDT
Works for me with 2.6.13-1.1526_FC4. Closed.

Note You need to log in before you can comment on or make changes to this bug.