Bug 167331 - via-rhine link down never up again
via-rhine link down never up again
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-01 13:21 EDT by Andrea Pasquinucci
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 12:27:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/cpuinfo (408 bytes, text/plain)
2005-11-22 11:17 EST, Andrea Pasquinucci
no flags Details
lspci -vv (7.86 KB, text/plain)
2005-11-22 11:19 EST, Andrea Pasquinucci
no flags Details
/proc/interrupts (682 bytes, text/plain)
2005-11-22 11:20 EST, Andrea Pasquinucci
no flags Details
/proc/devices (311 bytes, text/plain)
2005-11-22 11:21 EST, Andrea Pasquinucci
no flags Details
/var/log/dmesg (12.20 KB, text/plain)
2005-11-22 11:22 EST, Andrea Pasquinucci
no flags Details
/var/log/messages (22.34 KB, text/plain)
2005-11-22 11:23 EST, Andrea Pasquinucci
no flags Details
jwltest-mii-force_media.patch (917 bytes, patch)
2006-01-09 14:10 EST, John W. Linville
no flags Details | Diff

  None (edit)
Description Andrea Pasquinucci 2005-09-01 13:21:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
if for any reason (i.e. I turn off the switch) the link goes down, the only way of making it come up again is to 'rmmod via-rhine; modprobe via-rhine'
It did not happen with fc3 and does not happen on other machines with identical SW but different eth card.

PS: reporting this bug has been a real show-stopper, at every page firefox-1.0.6-1.1.fc4 has given me the warning 'error in encrypted connection to www.redhat.com: -5990' and it took 10 secs (timeout ?) to load each page! On top left sidebar was wrong! My problem???????

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1. turn off the switch or disconnect eth cable
2. turn on the switch or reconnect the eth cable
3. link does not come up, no packets in/out eth
  

Actual Results:  link come back up, packets exchanged

Expected Results:  no traffic

Additional info:

running '2.6.12-1.1447_FC4 #1 Fri Aug 26 20:29:51 EDT 2005 i686 athlon i386 GNU/Linux', fully updated fc4, with dmesg output

via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
ACPI: PCI Interrupt Link [LNKG] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:12.0[A] -> Link [LNKG] -> GSI 5 (level, low) -> IRQ 5
eth0: VIA Rhine II at 0xed800000, 00:0c:6e:db:8d:85, IRQ 5.
eth0: MII PHY found at address 1, status 0x786d advertising 01e1 Link 45e1.
Comment 1 Andrea Pasquinucci 2005-09-06 15:09:25 EDT
Re: PS. I think I understood what is wrong with firefox-1.0.6-1.1.fc4 and
https://bugzilla.redhat.com/ In firefox I had set "Use OSCP to validate only
certificates that specify an OSCP service URL" but at the same time I use a
proxy to reach internet. https://bugzilla.redhat.com/ specifies an OSCP service
URL, which is 12.166.243.30:80 but firefox tried to reach it directly and NOT
through the proxy! Indeed if in firefox I digit http://12.166.243.30 I get to
the OSCP responder thorugh the proxy, but if I try https://bugzilla.redhat.com/
the firewall stops the direct connection. I'll see if to file a bug to firefox.
Comment 2 Dave Jones 2005-09-30 03:20:05 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 3 Andrea Pasquinucci 2005-10-07 05:58:31 EDT
Sorry but the bug is still there. Exactly the same behaviour with
2.6.13-1.1526_FC4, so BUG STILL OPEN. 

I have the feeling that it is something that has happened between kernel 2.6.11
and 2.6.12
Comment 4 John W. Linville 2005-11-08 11:07:06 EST
Let's start with an update to the current upstream via-rhine driver.  Test  
kernels w/ such an update are available here:  
  
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please try those and verify that the problem still exists there...thanks!  
Comment 5 Dave Jones 2005-11-10 15:28:57 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 6 Andrea Pasquinucci 2005-11-16 08:11:58 EST
Something has changed, with 2.6.14-1.1637_FC4 via-rhine checks if the link is up
only when you start the module, so if at boot the link is up, via-rhine never
realizes if later it goes down/up ecc., and if at boot the link is down, it will
remain down until your rmmod and then modprobe again the module. Before it was
going down, but never up again, I do not know what is better :-)

Andrea
Comment 7 John W. Linville 2005-11-18 12:12:11 EST
It almost seems like your interrupts aren't being properly routed.  Have you 
tried booting w/ "acpi=off" or "acpi=noirq"? 
Comment 8 Andrea Pasquinucci 2005-11-21 10:24:18 EST
Tried with "acpi=off", "acpi=noirq" and "pci=routeirq", nothing!! Still does not
react. 

On the other side, I guess you are pointing to the right direction since also
some hot-pluggable things are not working as expected since kernel-2.6.12,
everything was working correctly with kernel-2.6.11 (for example, sometimes when
I insert a dvd or a cd it does not start playing automatically as if it has not
realized I put it in, and so on; but these cases are more random, sometimes it
works, other it doesn't). It could be a hw/sw interaction, but what leaves me
more puzzled is that up to kernel-2.6.11 included, everything was working perfectly.

Andrea
Comment 9 John W. Linville 2005-11-21 16:16:24 EST
Hmmm...well, it might be worthwhile for you to attach the output of running 
"sysreport" on the box in question. 
 
Also, what kind of system/motherboard is it?  Thanks! 
Comment 10 Andrea Pasquinucci 2005-11-22 11:17:14 EST
Created attachment 121354 [details]
/proc/cpuinfo
Comment 11 Andrea Pasquinucci 2005-11-22 11:18:23 EST
If it is good for you, I attach:

cpuinfo-20051122
devices-20051122
dmesg-20051122
interrupts-20051122
lspci-vv-20051122
messages-20051122

most interesting should be lspci and dmesg. System is 

AMD Athlon(TM) XP 2000+ 

with

  Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge       
        Subsystem: ASUSTeK Computer Inc. A7V8X motherboard

and

Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
        Subsystem: ASUSTeK Computer Inc. A7V8X-X Motherboard

Andrea
Comment 12 Andrea Pasquinucci 2005-11-22 11:19:44 EST
Created attachment 121355 [details]
lspci -vv
Comment 13 Andrea Pasquinucci 2005-11-22 11:20:44 EST
Created attachment 121356 [details]
/proc/interrupts
Comment 14 Andrea Pasquinucci 2005-11-22 11:21:36 EST
Created attachment 121357 [details]
/proc/devices
Comment 15 Andrea Pasquinucci 2005-11-22 11:22:41 EST
Created attachment 121358 [details]
/var/log/dmesg
Comment 16 Andrea Pasquinucci 2005-11-22 11:23:44 EST
Created attachment 121359 [details]
/var/log/messages
Comment 18 John W. Linville 2006-01-04 16:32:54 EST
Are you forcing the link configuration?  Could you attach the output of 
running ethtool on the link in question?  Thanks! 
Comment 19 Andrea Pasquinucci 2006-01-08 10:49:42 EST
Yes: in /etc/sysconfig/network-scripts/ifcfg-eth0 there is

ETHTOOL_OPTS="speed 10 duplex half autoneg off"

and 

~]# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: No
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000001 (1)
        Link detected: yes
Comment 20 John W. Linville 2006-01-09 14:10:54 EST
Created attachment 122962 [details]
jwltest-mii-force_media.patch
Comment 21 John W. Linville 2006-01-09 15:46:44 EST
Test kernels w/ the above patch are available here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please give those a try and post the results here...thanks! 
Comment 22 Andrea Pasquinucci 2006-01-12 08:12:56 EST
OK, now it works again! Thanks Andrea

PS. Will this patch go in the vanilla kernel sooner or later? 
Comment 23 John W. Linville 2006-01-12 13:44:35 EST
I expect that it will.  I'll certainly post it, probably in the next few days. 
 
Thanks for the testing! 
Comment 24 John W. Linville 2006-01-24 15:47:31 EST
Patch posted to netdev@vger.kernel.org on 1/24/2006...sorry for the delay! 
Comment 25 Dave Jones 2006-02-03 02:27:21 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 26 John W. Linville 2006-02-09 17:23:06 EST
Re-posted patch to netdev@vger.kernel.org on 2/9/2006, with long rebuttal to 
previous rejection...cross your fingers... 
Comment 27 John W. Linville 2006-05-19 15:26:42 EDT
Well, my patch was never accepted.  But, someone else posted a patch aimed at 
fixing the same problem.  I have incorporated it into the FC4 test kernels at 
the same location as in comment 21. 
 
If you are still using FC4, please give them a try and post the results here.  
Otherwise, please let me know which release (FC5, rawhide) and I'll try to get 
some appropriate test kernels posted as soon as possible...thanks! 
Comment 28 Andrea Pasquinucci 2006-05-24 02:50:39 EDT
Sorry, I switched all my boxes to FC5. If you can prepare a kernel for FC5 I
will test it, no problem. Andrea
Comment 29 John W. Linville 2006-05-25 10:47:52 EDT
FC5 test kernels available here:

   http://people.redhat.com/linville/kernels/fc5/

Thanks!
Comment 30 Andrea Pasquinucci 2006-06-04 14:45:48 EDT
Just manage to test it. It works fine, all OK. Andrea

Note You need to log in before you can comment on or make changes to this bug.