Bug 167362 - Export SRPM/RPM fails
Export SRPM/RPM fails
Status: CLOSED WONTFIX
Product: Red Hat Developer Suite
Classification: Retired
Component: RPM Plug-in (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Newsome
eclipse-bugs
:
Depends On:
Blocks: 167352
  Show dependency treegraph
 
Reported: 2005-09-01 17:21 EDT by Andrew Overholt
Modified: 2015-05-05 04:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-05 04:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2005-09-01 17:21:02 EDT
Description of problem:
Exporting a project that has changes (ie. needs creation of a patch) fails with
"Export RPM Errors" (Details gives "0" (no quotes)).

Version-Release number of selected component (if applicable):
eclipse-rpm-1.2.0-5

How reproducible:
Intermittent.

Steps to Reproduce:
1. Export a project to SRPM/RPM that has a newly-created patch.
2. Enter a ChangeLog comment.
3. Press Finish.
  
Actual results:
Error as above.  The also could be a:
    Unhandled event loop exception
    Reason:
    java.lang.NullPointerException
but I'm not sure since there were others in the terminal before this.

Expected results:
No error.

Additional info:
IBM JVM on i386
Comment 1 Andrew Overholt 2005-09-01 17:22:03 EDT
When this happens, I notice the progress bar says "Executing SRPM Export".
Comment 2 Andrew Overholt 2005-09-01 17:24:42 EDT
Sometimes the export fails with:

Export RPM Errors
  Error parsing the spec file in the project --
/home/overholt/testworkspaces-i386/pump/eclipse_pump.spec
Comment 8 Matt Newsome 2015-05-05 04:28:27 EDT
Closing this bug out due to its age and the assigned product.

Note You need to log in before you can comment on or make changes to this bug.